Survey123 Inbox list item titles and map labels

3677
6
Jump to solution
05-03-2017 06:26 PM
Highlighted
Occasional Contributor

I love the Inbox in Version 2 of Survey123. I appreciate the hard work that went into getting it out for this release.

Is there a way to specify the fields to display when listing the surveys in the inbox and labeling them on the inbox map?

As shown in these screenshots, it appears to use the GlobalId and OBJECTID fields first and then the rest of the fields in alphabetical order both for the list and labeling. If I could set it up to use the display field or to specify the fields that would help.

Tags (1)
1 Solution

Accepted Solutions
Highlighted
Occasional Contributor III

This can be configured using the Instance_Name setting in Survey123 Connect. It is located in the settings worksheet of the Excel file used when authoring the survey. The following blog post goes into more detail: https://community.esri.com/groups/survey123/blog/2017/04/24/understanding-the-instancename-setting.

View solution in original post

6 Replies
Highlighted
Occasional Contributor III

This can be configured using the Instance_Name setting in Survey123 Connect. It is located in the settings worksheet of the Excel file used when authoring the survey. The following blog post goes into more detail: https://community.esri.com/groups/survey123/blog/2017/04/24/understanding-the-instancename-setting.

View solution in original post

Highlighted
Occasional Contributor

Thanks for your response, Michael. This works great.

I have another related question. Is there a way to set up the Inbox map to use the same settings as the Survey's map or is there another way to set up the Inbox map settings?

When I try to use the inbox map it starts out zoomed way into the middle of the Atlantic ocean. When I press Home it goes to Melbourne Australia which is nowhere near my location.

Thanks again.

--joe

Highlighted
Esri Esteemed Contributor

Hi Joseph,

The box's map behavior has been identified as an issue in Survey123 app.

Reply
0 Kudos
Highlighted
Occasional Contributor

Hi James,

Is this still an issue being worked on?  I'm noticing this same behavior in a Survey I recently published (3.3.51), and wondering if I'm missing a setting.  

Thanks

-adam

Reply
0 Kudos
Highlighted
New Contributor II

I am experiencing the same issue but editing the instance_name and republishing the survey does not change anything. Am I missing something? 
I created a form using an existing feature service. I open up Survey123, and open the inbox and the points have labels based on fields that I have not specified. I set the instance_names as ${business_name}


Reply
0 Kudos
Highlighted
New Contributor

I had just the same problem. The changes won't show up until you refresh the survey on your local device. I had to delete the survey from my device using the ArcGIS Survey 123 app, and then re-download the survey, and then everything showed up!

Reply
0 Kudos