Survey123 image (annotation) question behavior after the tick

184
3
09-03-2018 01:19 PM
Highlighted
Occasional Contributor

We have a survey with an annotated image question at the bottom. All goes well until one goes to tick the icon lower right when done. The display goes back to the form, but, with the image question at the bottom again, out of sight. To view the thumbnail, scrolling is required. Does anyone else get this behaviour?

v3.1.144 (test device) and v3.0.149 (field test production device)

Tags (2)
3 Replies
Highlighted
Occasional Contributor

This looks to be a behaviour of a repeating image, not limited to the Android app.

  1. Non-repeating image field
  2. Doesn’t fall out of the screenshot
  3. Repeating image field
  4. Needs to be scrolled
  5. To find it again.

It is a bit of an annoyance to the field staff who would like to eyeball the image before form submission.

Reply
0 Kudos
Highlighted
Esri Regular Contributor

Hi Roger,

I have been unable to reproduce the issue using Survey123 Connect v. 3.0.142 and the Survey123 Field App v. 3.0.149 (current release versions).

Can you please verify that these are the versions of the app that you are testing with, and if so, provide your XLSForm to us for testing?  If you cannot upload it to the thread, let me know and I will send you a private message with my email address.

Best,

Brandon

Reply
0 Kudos
Highlighted
Occasional Contributor

Thank you for the reply.

I'll try uploading to the thread.

I am using Connect 3.0.128.

And have tested the survey in the Windows App 3.0.134 (screenshots are from there) and on two Android devices; one with 3.0.144 and 3.0.149.

They all do the same thing with the last (repeat) image.

Regards,

Roger.

Reply
0 Kudos