Survey123 Crashes with many images on lower power devices

93
3
02-22-2019 07:35 AM
Highlighted
New Contributor III

I've got a survey with 365 rows. Many of these rows are a set of similar groups that contain two media::images. The groups are hidden based on relevancy. There are about 65 notes that are empty except for the images.

My iPad Mini 4 cannot handle all the images and crashes on loading the survey. I've tested it on two different iPad Mini 4s. The little circle does not even spin upon tapping the Survey. It just sits there for a few seconds before the full app crashes.

On my iPhone Xs, however, the survey loads just fine (albeit slowly with all of that content).

Testing/Debugging

I've tried reducing the number of images to about 10 and then the survey works just fine on the iPad Mini 4.

What other testing would you suggest? Is there a file size of all the survey images that tends to cause crashes? A max number? I can try different optimization strategies but for the sake of time want to know what is optimal. Additionally, are there any known issues with big forms, lots of content, and crashing?

Reply
0 Kudos
3 Replies
Highlighted
New Contributor III

Elliot,

I, too, am having issues with loading surveys on some older devices, both phones and tablets. "Loading Survey" may appear, then the entire field app crashes. In my case the survey has a large external_choices table (7000 rows), and the frequency of crashing decreases when fewer rows are included in this table. Crashing is sporadic, however, not every time the survey is opened (~10% of the time).

Brandon Armstrong‌ has been looking into this on my behalf. I'm hoping it's a bug, as I hadn't encountered this issue on previous versions of Survey123 (<3.1), but had also not attempted this large of a dataset previously. Could be our equipment is just approaching obsolescence though.

Braden

Reply
0 Kudos
Highlighted
New Contributor III

FYI: I never heard anything as to whether this was a bug or not, but this hasn't been an issue for me since 3.5 was released.

Highlighted
New Contributor III

Thanks for letting me know that it is working better as of 3.5. I'll circle back to this issue on 3.6 and see how it works.

Reply
0 Kudos