Survey123 Connect freezes and takes a very long time when updating from CSV

675
17
03-17-2021 08:58 AM
MatthewGuilliatt
New Contributor III

When I am working on Survey123 Connect, every time I save my excel sheet and trigger the update in Survey123 Connect it gets stuck on the "Converting XLS Form" stage for usually around 5 minutes, the program goes to not responding, but then eventually unsticks itself and gives me the updated form. I've also noticed it does this when I do other things, e.g. creating a new survey or opening an existing survey from the main page.

This seems a bit ridiculous, as it happens even on very short survey forms. Can I get some suggestions on how to fix this? Do I need a clean install of Survey123?

Tags (1)
17 Replies
Philip-Wilson
Esri Frequent Contributor

Hi @MatthewGuilliatt,

Can you confirm the exact version of Survey123 Connect you are using, please check the About screen in main menu?

Was this happening with the previous version, or is it new in the latest version?

Are you able to share the xlsx file and csv files being used in the survey, so we can take a closer look to see what is causing the slow load times. If you do not want to share publicly, please send me a direct message with the files.

Regards,

Phil.

0 Kudos
MatthewGuilliatt
New Contributor III

Hi Phil,

I am using version 3.12.230. I'm a new user so haven't used a previous version. Attached an example of one my files, but I'm having problems with all of them even newly created ones.

0 Kudos
Philip-Wilson
Esri Frequent Contributor

Hi @MatthewGuilliatt,

This is likely related to the choice list management and other database related changes made in 3.12 and 3.11, which in some cases we have seen causes Connect to take a long time to refresh the survey preview.

Good news is that improvements have been made in the 3.13 beta builds, which appear to resolve this issue. We will have the 3.13 beta builds for Connect and the field app available on the Early Adopter Community site later this week. Please keep an eye out for the latest beta builds.

Regards,

Phil.

0 Kudos
ChrisShuck
New Contributor III

Same problem here. This happens intermittently. Most of the time I can save without an issue. Then I'll have a streak of 3 to 10 times that it freezes and I have to force quit and re-enter. Occasionally I have to republish a whole new version of the form to get it to work. This never used to happen prior to the last update. This happens on very simple forms and complex forms. I can't find any rhyme or reason for it. Very frustrating. Version 3.12.232.

0 Kudos
Philip-Wilson
Esri Frequent Contributor

Hi @ChrisShuck,

This is likely related to the choice list management and other database related changes made in 3.12 and 3.11, which in some cases we have seen causes Connect to take a long time to refresh the survey preview.

Good news is that improvements have been made in the 3.13 beta builds, which appear to resolve this issue. We will have the 3.13 beta builds for Connect and the field app available on the Early Adopter Community site later this week. Please keep an eye out for the latest beta builds.

Regards,

Phil.

ChrisShuck
New Contributor III

Thanks for the update. I just downloaded it and will be testing it today. 

0 Kudos
ChrisShuck
New Contributor III

I've been using the new version of the app (3.13.110Beta) all day and have not had the issue with the app freezing upon saving. It has crashed twice inexplicably upon saving, but otherwise it has worked fine.

Philip-Wilson
Esri Frequent Contributor

Great @ChrisShuck, thanks for the feedback and testing the 3.13 beta builds.

Phil.

0 Kudos
MatthewGuilliatt
New Contributor III

Thanks both - I look forward to getting access to 3.13 then.

0 Kudos