Survey123 Child Survey not reading domains from Parent FC to populate relevant answers. Ideas?

84
3
12-14-2018 12:07 PM
Highlighted
New Contributor II

I have a survey with relevant based on a type of facility. The domain's match for the parent and child FC where the domain would be pulled into the survey to give certain questions based on the facility type. I am noticing the relevant code block does not work for autopopulated answers. I have to choose the facility type rather than pull it from the parent and have the relevant questions populate for me. Is this something that will be addressed? Am I missing something?

The Child Table reads the domains but the relevant "Code" will not activate unless done manually. Suggestions?

The field, type, and length are all the same as well as the domains. If I remove the domain from the parent it will work, but I'd like to keep it for the field users. 

Reply
0 Kudos
3 Replies
Highlighted
Esri Regular Contributor

Hi Sean,

Are you creating your survey based off of an existing feature service?  Can you please provide a copy of your XLSForm so that we can get a better idea of the data structure you are referring to?

Thanks,

Brandon

Reply
0 Kudos
Highlighted
New Contributor II

Hey Brandon, 

I tagged you in an attachment because I cannot find where to attach a file in a thread...........let me know if you get it. 

Reply
0 Kudos
Highlighted
Esri Regular Contributor

Hi Sean,

Please send the attachment(s) to barmstrong at esri.com 

Thanks,

Brandon

Reply
0 Kudos