Survey question display issues in the iOS mobile app

176
2
07-30-2019 11:11 AM
ElijaFlores1
New Contributor

Hello,

I am having some issues with my survey form displaying questions, especially in the mobile app on my iPhone (we tested on an iPhone 7 and iPhone X with the same issues). The survey displays the first half of the survey questions, but then it cuts off and the questions are completely absent. The form displays properly on the mobile app on my iPad as well as on my Chrome browser on a desktop computer, so I am not sure what's going on.

For the iPhone mobile app, I have tried the following but with no luck:

- delete and re-download the survey in the mobile app

- uninstall and reinstall the mobile app from the App Store

- check if I have the latest version installed (it's 3.5.164)

I'm not sure if it is a bug with the app itself, but answers or suggestions would be appreciated! For now, I am using my iPad for fieldwork collection, but this leaves others on my team to use a paper form until this issue is resolved (we only have one iPad to use)

Many thanks!

Elija F.

Tags (2)
0 Kudos
2 Replies
Philip-Wilson
Esri Frequent Contributor

Hi Elija,

Can you please share a coy of your xlsx form? It sounds as though it could be related to the questions and configurations in your survey, not just the app itself.

You mention the issue occurs on iPhone, have you tried Android or Windows? Does the same thing happen, or only on iOS?

Also, did it work as expected in 3.3 or earlier, and is this just a new issues with latest release 3.5?

Phil.

0 Kudos
NicolasRoger
Occasional Contributor

My team is reporting the exact same problem with their iphone!

It was working fine last year on iphones, but it no longer do this year. The survey works fine or any other devices. They tried deleted Survey123 and reinstalling. So I guess they are running the latest version.

I can provide my .xlsx to any Esri staff that need it.

I have really no idea how to fix this one.

0 Kudos