Survey publishing error: supportsApplyEditsWithGlobalIds

5614
48
Jump to solution
06-21-2017 03:36 PM
Highlighted
New Contributor II

I am currently trying to publish a survey with a custom SDE-based feature service.  The service includes the point feature layer with a related table (relationship via a GUID; for repeats);the related table has attachments enabled.  

The submission url in the form has been edited to that of the feature service, so something like:

http://utility.arcgis.com/usrsvcs/servers/.../rest/services/[FolderName]/[ServiceName]/FeatureServer

When attempting to publish the survey I receive the error:

The custom feature service submission url is not compatible with this survey (The feature service does not meet the requirements for a survey with repeats - supportsApplyEditsWithGlobalIds)

I have not been able to find much about this particular error online--anyone who overcame a similar issue? The error message seems to indicate an issue with the relationship to the related table? But I was able to publish a survey with this database structure previously with no problems.  I have also tried to publish the survey with a GLOBAL ID-based relationship, but this also did not work.

Thanks all.

1 Solution

Accepted Solutions
Highlighted
Esri Regular Contributor
48 Replies
Highlighted
Esri Esteemed Contributor

Hi Samantha,

Please refer to Use Survey123 with existing feature services—Survey123 for ArcGIS | ArcGIS  for more information on feature service configuration.  The easiest way to have a service compatible with Survey123 is to enable the 'Sync' operation on the Feature Service- this will set up the properties for the applyEditsWithGlobalIds to be true.  If you can't get this property enabled, it's likely you've missed a configuration setting, such as ensuring that the service has a gloablid field.

Highlighted
New Contributor

James ~ I also have this problem. I checked my data and I have Global IDs and the feature service is set to sync. However, in the documentation you referenced, it says "The data cannot be versioned." Why is that the case? That's going to be a problem for us. Do you have a suggested work-around so we can continue to use a feature service that's linked to a versioned SDE? Thank you.

John

Highlighted
New Contributor II

John,

Did you ever get a work-around or get this working?  I am in the same situation with the versioned SDE.

Becky

Reply
0 Kudos
Highlighted
Esri Regular Contributor

Hi Becky - the property "supportsApplyEditsWithGlobalIds" cannot be enabled on versioned services. This is a feature service limitation.

 

Highlighted
New Contributor III

This is really problematic, as we rely very heavily on versioning for data integrity. I understand it doesn't work with traditional versioning, but will it work with the new Branch Versioning model?

Reply
0 Kudos
Highlighted
Esri Esteemed Contributor

Hi Jay,

Yes branch versioning does support the 'supportsapplyEditsWithGlobalIds' property.

Reply
0 Kudos
Highlighted
New Contributor III

Great, thank you! Yet another reason to push our full migration to Pro sooner rather than later.

Reply
0 Kudos
Highlighted
New Contributor II

Having noticed some other users having a similar issue, I thought it might be worthwhile to mention that my particular issue was traced back to ArcServer compatibility (related tables only supported with ArcServer 10.3.1+ using the lastest Survey123 version).

(For the record, I was not trying to use versioned data, so that wasn't a factor in my instance of the error.)

Reply
0 Kudos
Highlighted
New Contributor II

I also got a similar error, please see attached showing screen shots for reference.

I have a hosted feature layer on our organization’s AGO site.  The layer has a related table which uses GlobalID's for the relationship – it was made using methodology described here.

Screen shot #1 shows the error, so I went to Apply Edits from the Supported Operations section at the bottom of the respective Service URL pages for the layer and related table (screen shots #2 and #3, which appears similar to this.

I selected "True" for Use GlobalIds for both and applied edits, but this didn't save the "True" setting. 

Will having the Use GlobalIds set to "True" solve the issue and what role does the note on top "This operation is only supported via POST" play as far as publishing in Survey123?

As far as the submission_url on the Excel settings tab, the automatically generated URL is - https://www.arcgis.com/sharing/rest/content/items/0d7f1a3e66304036a69c52aa1d1c640e

The URL obtained from the item details page, as described hereis -

https://services1.arcgis.com/8CpMUd3fdw6aXef7/arcgis/rest/services/Controller_Related_Table/FeatureS...

The error message comes up when I use either of the URLs.  Which URL should be used in order to publish in Survey123?

Thank you in advance.

Reply
0 Kudos