Survey publishing error: supportsApplyEditsWithGlobalIds

7301
48
Jump to solution
06-21-2017 03:36 PM
SamanthaNakata1
New Contributor II

I am currently trying to publish a survey with a custom SDE-based feature service.  The service includes the point feature layer with a related table (relationship via a GUID; for repeats);the related table has attachments enabled.  

The submission url in the form has been edited to that of the feature service, so something like:

http://utility.arcgis.com/usrsvcs/servers/.../rest/services/[FolderName]/[ServiceName]/FeatureServer

When attempting to publish the survey I receive the error:

The custom feature service submission url is not compatible with this survey (The feature service does not meet the requirements for a survey with repeats - supportsApplyEditsWithGlobalIds)

I have not been able to find much about this particular error online--anyone who overcame a similar issue? The error message seems to indicate an issue with the relationship to the related table? But I was able to publish a survey with this database structure previously with no problems.  I have also tried to publish the survey with a GLOBAL ID-based relationship, but this also did not work.

Thanks all.

48 Replies
JohnathanHasthorpe
Esri Regular Contributor

Please feel free to email me at jhasthorpe@esri.com - send through your survey xls and I'll take a look.

This should be the form with buildings and inspections.

Thanks

John

DanielMcIlroy
Occasional Contributor

I have started getting this error on one of my surveys (it is very old, was created in the web generator) and I use it for device testing and has become a good test survey.

I upgraded to version three of the iOS app on my phone yesterday and now i can't submit the responses and i get this error (supportsApplyEdits). my iPad hasn't been updated and I can still submit responses to the same survey without a problem.

I have tested another survey on my phone and I am able to submit without problems. seems a bit strange to me. Any ideas?

0 Kudos
JohnathanHasthorpe
Esri Regular Contributor

Hi Dan 

We made a change to 3.0 that requires all services to supportsApplyEditsWithGlobalIds (this should be true).

You will need to enable this capability on your service.

Feature Layers and supportsApplyEditsWithGlobalIds: Starting with version 3.0 you will no longer be able to submit surveys or publish/republish a survey against a feature service that does not have the supportsApplyEditsWithGlobalIds property set to true. While this requirement is not new, we previously only enforced it for surveys with repeats. It is therefore possible that your existing ArcGIS Online or ArcGIS Enterprise feature services don’t have this capability– so please check them to ensure that they will work when you update. The easiest way to enable this property is to simply enable the sync capability (Synchronization) on your feature service. Please follow instructions in the Allow offline editing or collaboration section of the Manage hosted feature layers—ArcGIS Online Help | ArcGIS help topic for details on how to enable the sync capability.  If working with ArcGIS Server, remember that you cannot turn on sync if your data is versioned or if your layer lacks an indexed GlobalID field.

Thanks

John

DaveOrlando
Occasional Contributor III

Thanks John,

Can you please provide the link to where this was documented to your users, I don't see it in the What's New.

Thanks

0 Kudos
JohnathanHasthorpe
Esri Regular Contributor
DanielMcIlroy
Occasional Contributor

Hi John, unfortunately the "supportsApplyEditsWithGlobalIds" is true, but the form still won't submit. Strange. It is a basic form, no repeats or anything like that, although it does have photo option. It was created using the web designer in September 2016.

0 Kudos
JohnathanHasthorpe
Esri Regular Contributor

Hi Dan 

Can you share a print screen of the error you are getting? The issue should not relate to the 3.0.

I would like to get access to the survey and service if possible - can you email me at jhasthorpe@esri.com?

Thanks

John

EricLutz
New Contributor

Dear John,

I have the same problem. I have a survey that no longer works due to the same "supportApplyEditsWithGlobalIds" issue. I following the instruction republished my Feature Service this morning and problem remains. Here is a detailed description of my data and settings:

  • Two surveys set up for add hydrant flushing and valve exercise records using an "existing feature service";
  • That feature service contains two feature layers (wHydrants and wSystemvalves) and two tables (Hydrant_flushrecords and valve_ExerciseRecords) that related to hydran and valve layers using GlobalID and GUID; All the layers and table have GlobalID and the GlobalID was indexed.
  • During the publishing, the sync option was enabled. see picture1.Publish setting
  • After the service was published, I notices that the property of "supportApplyEditsWithGlobalIds" for the two feature layers was "false" and for the two tables are "true"! I guess that it is the cause for the submission problem of the survey!

      wHyrant property

      wSystemvalve Property

     Flush Table Property

    Exercise Table Property

  • I used both Survey123 Alpha 3.0.58 version and 2.8.4 versions. During the "upload" and Alpha version return the same "supportApplyEditsWithGlobalIds" error, but 2.8.4 version worked.
  • Both survey can be opened, but return the same error when click the send button!

I am frustrated by "how to set the "supportApplyEditsWithGlobalIds" to "true" for this type of feature service!?

Thanks,

Ming

0 Kudos
MarkBennett
New Contributor III

Sorry John, I used my client's account to ask the question above. Please reply this one if you have a answer! 

Ming

0 Kudos
JohnathanHasthorpe
Esri Regular Contributor

Hi Ming

It looks like the fix for adding the capability did not work. Are you able to share the file geodatabase and I will take a look: jhasthorpe@esri.com and share the exact steps required.

Thanks

John