Survey looks like it downloads, but fails to launch correctly

576
12
Jump to solution
11-16-2018 09:01 AM
New Contributor III

Link from collector to launch a survey, opens survey123 on android device, goes to download the survey, goes through the downloading, unpacking, thumbnail, and gives an error that it didn't download. However, it is there, and I can open it, but it will not open from the collector url. See the attached screenshot. 

I have published and re-published the survey, uninstalled survey123 and reinstalled, and tried it on 2 different devices. No change. What am I doing wrong?

Here is the url:

arcgis-survey123://?itemID=b6dbe4d4adf245d786646df747b871b3?field:PL_LCLTY_ID={GlobalID}

Also attached is the survey.

Reply
0 Kudos
1 Solution

Accepted Solutions
Esri Contributor

Hi Gregory! Can you test the items below and let me know the results?

  • Try to open arcgis-survey123://?itemID=b6dbe4d4adf245d786646df747b871b3 from the Collector App (without passing any fields) - does the Survey download?
  • Adjust the URL to arcgis-survey123://?itemID=b6dbe4d4adf245d786646df747b871b3&field:PL_LCLTY_ID={GlobalID} - does the Survey download?

Can you also verify the itemID? To do this, log into ArcGIS Online (or Portal) > Content > Survey-SurveyName > Form. The item ID appears after "id=" in the URL.

View solution in original post

12 Replies
Occasional Contributor

Our issue is similar but the download of the survey never finishes (green rings spins and spins) and no error codes are given. Even if the survey is downloaded to the device before accessing the URL in Collector, the callout doesn't work. Older custom URL callouts still work.

Reply
0 Kudos
Esri Contributor

Hi Gregory! Can you test the items below and let me know the results?

  • Try to open arcgis-survey123://?itemID=b6dbe4d4adf245d786646df747b871b3 from the Collector App (without passing any fields) - does the Survey download?
  • Adjust the URL to arcgis-survey123://?itemID=b6dbe4d4adf245d786646df747b871b3&field:PL_LCLTY_ID={GlobalID} - does the Survey download?

Can you also verify the itemID? To do this, log into ArcGIS Online (or Portal) > Content > Survey-SurveyName > Form. The item ID appears after "id=" in the URL.

View solution in original post

Occasional Contributor

Thank you for your help. I receive an error saying the survey was not found when I try the URL you've supplied.

Reply
0 Kudos
New Contributor III

Sorry about that, but I cannot share my surveys outside my work. 

Reply
0 Kudos
New Contributor III

Thank you!

  • Try to open arcgis-survey123://?itemID=b6dbe4d4adf245d786646df747b871b3 from the Collector App (without passing any fields) - does the Survey download?

Yes, it downloaded.

  • Adjust the URL to arcgis-survey123://?itemID=b6dbe4d4adf245d786646df747b871b3&field:PL_LCLTY_ID={GlobalID} - does the Survey download?

Yes, it downloaded and passed the value.

New problem, but not related I don't think. I have a repeating table in the feature service, and the system hangs up on trying to upload new data. One thing works, and another thing breaks...

Reply
0 Kudos
Occasional Contributor

I will contact tech support again even though they suggested posting here.

Reply
0 Kudos
New Contributor III

I am having a similar problem. I just updated a survey I used last year for the new season and downloaded it to my phone. When I tried to launch it through the collector map, it gave me a message that the survey had not been downloaded. It then attempts to download the survey and keeps the message at the bottom of the screen saying the survey has not downloaded. I have checked to see that the ID is correct and it is. I have deleted all the surveys from my phone and re-installed the app and downloaded the survey that was not opening and an older one that opened in an older version of the app (I have not used it since the app was updated a couple of times). They both give the same result as above.

Reply
0 Kudos
Esri Frequent Contributor

Hi Chris,

What version of Survey123 and Collector are you using? Also on what device (make/model/OS version)?

Are you signed into Survey123 when attempting to download the survey via the URL? Have you tried downloading the survey from the Downloads menu in the app, does that work successfully?

Phil.

Reply
0 Kudos
New Contributor III

Hi Phil,

I’m using Survey 123 Connect version 3.3.51 to create the survey, but I was trying to update it in 3.0.142. When I was unsuccessful at logging in to update it, I installed the newer 3.3.51. Collector is version 18.0.3, build 1033. Survey 123 app is 3.3.64. The device is a Samsung Note 4 with an OS 6.0.1.

I have only tried downloaded the survey from the Download menu in the app while signed in. I have many areas that have spotty satellite connection so I need to have these forms offline. I have not tried downloading using the URL. Is this a new thing that is necessary?

Thanks

Chris

An Accredited land trust

Chris Young

Stewardship & GIS Coordinator

Columbia Land Conservancy

49 Main Street

Chatham, NY 12037

518.392.5252 ext. 221

chris.young@clctrust.org<mailto:chris.young@clctrust.org>

www.clctrust.org

Conserving rural landscapes.

Connecting people to the land.

Reply
0 Kudos