Survey 123 send stuck on Getting service information

5694
42
02-18-2019 02:26 PM
AaronWorthley1
Occasional Contributor

I am encountering a problem where my survey gets stuck when trying to send with the spinning wheel and "Getting Service information" then the name of the 2nd of 2 related tables.

Based on other threads for similar issues, I've rebuilt the entire geodatabase, and overwritten the feature service, I've updated and republished the survey, but this continues to happen. I can't get any surveys to upload.

I had this working fine previously, but I had to update the feature service and ended up making a whole new survey based on the old one but referencing the new FS.

Is there any way to troubleshoot what is going on? I'm running v3.2.265 on ios. The feature service is hosted on AGOL, and has 2 related tables which are populated by the Survey. The hang appears to be on the second of the 2. The 2nd table is referenced in a repeat in the form, but it doesn't matter if I add data to that part of the form or not.

I'm able to create features and rows in the related tables in ArcGIS Pro with no issues. Since I've already rebuilt everything, I'm not sure how else to figure it out.

0 Kudos
42 Replies
JamesTedrick
Esri Esteemed Contributor

Hi Jon,

Given your description, it sounds like the issue would be that the survey on the device has the old form's information (form lookup is done by item id).  There are a couple of processes that could be used to recover the data; this would work best by copying the data from the device to a PC:

- I have a sample script that will take the data and produce CSV files: GitHub - tedrick/ReadS123DB: Convert the survey data stored in the Survey123 Field App into a set of... 

- Download the new survey onto the devices.  Then can follow the steps in Troubleshoot—Survey123 for ArcGIS | ArcGIS to copy over the data; in addition to these steps you would need to open up the SQLite database and update the path value in the surveys table with the ID of the new form.

0 Kudos
AnnetteDoonan
New Contributor

Hi

I am having an issue with my survey. Survey was designed using Survey 123 Connect and has been working no problems. I changed the order of the questions, republished it and seemed fine. When you click on send it gets stuck  trying to send and all you see is the spinning wheel and Getting Service information. The survey is being used on ipads and phones all have same issue and I have since republished it but it keeps getting stuck. I am not using ArcGIS Pro with the survey at all.

Any advice on how to solve this?

0 Kudos
BrandonArmstrong
Esri Regular Contributor

Hi Annette,

Please capture and provide a log file taken during the time of one of the crash.  Instructions regarding how to do this can be found in the following linked help document...

Troubleshoot—Survey123 for ArcGIS | ArcGIS 

Select the option to 'log as file' and then upload the file to this thread (Use Advanced editor options)

0 Kudos
ArapahoeAdmin
New Contributor II

Hey Guys,

  I was having the same problem.  I went into AGOL and shared the form and the feature layer with my organization and re-sent my survey from my IPad and it worked.  It may be a simple permissions issue.

Hope this helps someone!

PeterMacKenzie2
New Contributor III

I too shared with the entire org. Then I was able to submit.

I then changed to just the group within the org that I wanted to share with and was still able to submit. There are several components to a form - the form, the feature layer etc. my hunch is that a refresh of the sharing for all of these components is what made it work. 

0 Kudos
WDFW_HabitatProgram
New Contributor

After experiencing this problem, I inspected the permissions within the Survey123.arcgis.com site's page for the survey, and sure enough, the permissions within the collaboration tab warned that I was the only one able to view/submit. Assigning permissions to the appropriate group there fixed this problem. @James Tedrick: it's kind of weird having permissions in both AGOL and on the Survey123 site, and it seems like they're not always in sync.

0 Kudos
JamesTedrick
Esri Esteemed Contributor

Thanks for the feedback.  Survey123 uses ArcGIS Online's permissions structure, but needs to share multiple items for different purposes (for submitting, for viewing), so we cannot use AGOL's built-in sharing check (that you would see if sharing a web map, for example).  We recommend using the Survey123 website to control the sharing of the surveys.

0 Kudos
SamanthaGriffore
New Contributor III

I have a similar issue getting stuck on "Getting Information" when trying to re-publish a Survey from Connect (3.3.51). I have just added 3 new hidden text fields to a repeat section of the form (related table). The fields seem to be working great (tested calculations), but when I go to republish the form, I acknowledge that I've added new fields and say YES overwrite, but it just gets stuck on the first step, "Getting Information" and never progresses. 
I've tried "deleting" the iteminfo file (moved it to a local folder), which just created another survey on Connect which is now also linked to the same SurveyDesign folder (so I have two surveys of the same name pointing to same folder). I put the iteminfo file back and redownloaded the survey from AGO and re-added the fields, still getting stuck. 

On the help pages it says that you can add new fields to a Survey without having to recreate the Feature Service. I would really like it if this were true as it would add a lot of work to my methodology if not.

Any help is appreciated!!

JamesTedrick
Esri Esteemed Contributor

Hi Samantha,

This sounds like an issue when publishing changes that are only made to a repeat table (no changes to the parent table).  You can either add a field in the parent table or add the fields to the repeat table outside of Survey123 (say, via the Item Details page in ArcGIS Online/Enteprise) and then republish the form.

JohnMarino
New Contributor III

Hi James, as of today, this bug is still occurring, as I just encountered it. Completing the steps you listed was the only was I able to publish my problematic form.

0 Kudos