Survey 123 & Federated Services: Clarification

1135
4
06-09-2017 05:57 AM
TL2
by
Occasional Contributor III

I would like more detail/documentation on publishing surveys with services federated with my portal and server.

What are the requirements for the published feature service?

I would like to take an existing survey, add the rest end point to the submission url and publish.  Currently I am getting this error.

My work flow:  

1. Publish my survey to ArcGIS Portal 10.4.1.

2. Export my HFS as FG.

3. Create Service MXD with feature class from exported FG. (enabled attachments after adding globalids.  Ran 'add attribute index geoprocessing tool')

4. Copy Survey, insert rest end point of federated feature service. (update form_id to that of the layer from service)

5. Receive Error. 

Alternatively:

1. Using the same federated feature service.

2. In Connect adding a new survey.

3. It creates the new survey with the correct schema but the submission URL is not the rest endpoint, its a feature service item description url.

4.  Also when publishing I receive the same error as above.

0 Kudos
4 Replies
JamesTedrick
Esri Esteemed Contributor

Hi Tucker,

For federated services, the submission_url will show the item description URL instead of the service endpoint - this is to allow the form to properly associate itself with the service's item in the Portal.  I'm attempting to replicate the error described.

0 Kudos
MariaNieves
New Contributor III

I am getting the same error and followed similar steps as Tucker. 

0 Kudos
TL2
by
Occasional Contributor III

I was able to use the submission url successfully.

Archiving must be enabled.  (add attribute index geoprocessing tool did not work, maybe I did that wrong)

Also, the submission url formatting

IS https://domain.com/arcgis//sharing/rest/content/items/xxxxxxxxxPortal Item IDxxxxxxxxxx

IS NOT https://domain.com/arcgis/home/item.html?id=xxxxxxxxxPortal Item IDxxxxxxxxxx

0 Kudos
TL2
by
Occasional Contributor III

James Tedrick

I have been trying to set up a survey which is tied to a federated service with a repeat and attachments on both the FS and Table.  I am receiving the error below when attempting to publish even though both of my services are set to Supports ApplyEdits With Global Ids: true.

My FS - ID: 0 in service MXD.  Global Ids enabled, attachments enabled (based on GIDS), editor tracking enabled, archiving enabled, indexed on globalid field (unique: yes, ascending: yes) Supports ApplyEdits With Global Ids: true at rest end point.

My Table - ID: 1 in service MXD. Global Ids enabled, attachments enabled (based on GIDS), editor tracking enabled, archiving enabled, indexed on globalid field (unique: yes, ascending: yes)  Supports ApplyEdits With Global Ids: true at rest end point.

My FS and Table relationship: Simple, 1-M, No Notifications, Origin is FS, Dest. is Table based, primary key: GlobalID, foreign key: parentrowid

I have created my survey and published it to the portal as a HFS.  I then export as file geodatabase and import the feature layer and table into my sde and create attachments etc and relationships. 

Scenario 1

I publish an mxd with the IDs noted above.  When I add the item description URL to my survey and delete the .itemINFO file I recieve the following error...

I have verified that both my FS and Table both have Supports ApplyEdits With Global Ids: true.

Scenario 2

When I create a new survey based on the Feature Service option within Survey123 and select the same feature service as above I receive the same error as above.

In Scenario 2 it sets my attachments to false (probably because those image fields to not get carried through the feature layer. 

Should I be able to use a feature service with a related table federated with portal in a survey??

UPDATE: I changed my feature-table relationship to GlobalID and parentrowid (guid) and that fixed one error.

0 Kudos