Survey 123 Conditional Formatting Featured Report Tables

516
2
07-19-2019 11:24 AM
OliviaNiziolek
New Contributor

Hi all,

 I have a small formatting problem that I just cant seem to solve. If anyone has any ideas on what I am missing please let me know. 

I have a survey and export that  asks a questions. There are three answers you can give  1) the correct answer (yes, no , na) 2) the incorrect answer (yes, no, na)-> this conditionally prompts two other questions 3) A third answer where you don't directly answer the questions but write down Notes (essentially conditionally you get 1 additional question)

The survey works great. I am working on the  feature export, each question is a line in a table (within word). I would like all the excess cells to not show up when not needed. 

Here is a snip of my document.  The results of this export are an extra row when the response is the correct one or the incorrect one.Clip of export document where the export has an extra row that I would like to get rid of

Example of export using   "Capture1"I tried to solve this by putting the opening conditional statement behind the end of the previous  closing statement ( same row) but I get an error stating  "Error: The loop with tag "Q49== "Notable Observations" is unclosed. The loop with tag "Q49 == "Notable Observations" is unopened. What I imaging the solutions should be but gives me errors

Error preventing export

Thoughts?

0 Kudos
2 Replies
JodyZhengLiu
Esri Contributor

Hi Olivia,

Is it possible to share the survey xlsx form and report template so we can have a test? You could sent them to zliu@esri.com. Thanks!

Best regards,

Jody Zheng Liu

0 Kudos
LiudmilaMaslova
New Contributor II

Hello, Zheng

Do you have any updates on the error :The loop with tag "" is unopened ?

I wanted to modify feature report to my needs from the sample template created in Survey123 for my xlsx file, but I got the error with my templet saying Error: An error occurred when checking the report template. The loop with tag "" is unopened. So, I was trying few things, and the same error appeared every time. So, I renamed the sample template created by Survey123 to see if the original sample templet will give me the same error, and I redownloaded it, and I got the same error. 

How would I overcome this error?

Thank you

0 Kudos