Submitting survey on the mobile app doesn't trigger webhook

212
4
06-16-2019 10:07 AM
Highlighted
New Contributor II

I have set up a webhook with integramat.  I can't get the webhook to trigger when I submit the survey on my mobile device for on the survey123 app on windows.  If I am on the survey123 website, select the survey, click on data, select a survey, click edit the individual survey and submit.  The webhook works great.  See below.  

I want my guys to submit a survey in the field and have the webhook run when the do that.

Any suggestions?

Tags (3)
Reply
0 Kudos
4 Replies
Highlighted
Esri Frequent Contributor

Hi Frank,

What version of Survey123 field app are you using? Have you updated the survey on the device (re-downloaded) after adding the webhook?

How did you create the webhook, via survey123 website?

Phil.

Reply
0 Kudos
Highlighted
New Contributor II

Still nothing.  I reloaded the app on my phone, reloaded the survey and still nothing.  But when I edit the survey from the survey123 website and submit it works perfectly.  This is what I get when I run a test and use my phone to submit. 

Reply
0 Kudos
Highlighted
Esri Frequent Contributor

Hi Frank,

Support for webhooks when editing surveys in the field app is only supported in 3.5, not 3.3. The current released version of the field app only supports sending a webhook and new collect surveys. The next release 3.5 will be available within the next two weeks. 

In the meantime you can try and test webhooks via editing surveys in the 3.5 RC field apps builds which are available on EAC here.

Regards,

Phil.

Highlighted
New Contributor II

That worked great,  Thanks for the help