sharing a survey in portal, not show to the others members.

59
5
03-26-2019 10:23 AM
Highlighted
New Contributor III

portal 16.0, create a survey to a feature in sql and share the survey with a group. Call the survey website with the redirection to the portal , login with my user and i see the survey and also print the report. Then one of the user that is in the group, go to the survey website and login and the survey is not showing. only show if i change the owner to the user that is login. we are goin to have aprox 200 users using the survey and want the users to use the website to print a report. what is happen??

Tags (2)
Reply
0 Kudos
5 Replies
Highlighted
Esri Regular Contributor

Hi Jose,

What is the method that you used in order to share the survey to the Group?  Have you used the Collaborate options within the Survey123 website?  In your case, you would use the sharing options available through the 'Viewer' section of the Collaborate tab 'Share survey—Survey123 for ArcGIS | ArcGIS. Also, have you tested sharing other items to the group and test the ability for group members to access them?

Best,

Brandon

Reply
0 Kudos
Highlighted
New Contributor III

I shared via collaborate. I connect as the user and see in portal all the shared items. Also as the user I use the survey app and go to downloads and see the surveys that I share. Also have the capacity to collect and submit a survey as the user.

attach are images.

Reply
0 Kudos
Highlighted
New Contributor III

checking with the last update for s123web and the problem is the same. only if the layer that the survey use is hosted works but is the survey is from a feature in sql the other people not see the survey in the s123website. they see the survey in the s123 app in windows and submit records.

I try the viewers section in s123website and this create a hosted feature stakeholder and then says an error.

enterprise portal is 10.6

using active directory and internal portal users.

Reply
0 Kudos
Highlighted
Esri Esteemed Contributor

Hi Jose,

To double-check, you are seeing this error on a survey with an existing feature service published by ArcMap or ArcGIS Pro, correct?  One limitation is that a hosted layer view cannot be created in this situation; that being said the Survey123 website should not be trying to create one.

Reply
0 Kudos
Highlighted
New Contributor III

First, I want to thank you for the conversation we had at the developer summit 2019. With your explanation and how to troubleshoot , i was able

to solve the problem I had with a survey.

Now i have this problem and in reply, Yes ,the feature was published with arcmap to entrerprise portal 10.6 and create the feature in microsoft sql.

Then, how can i make that the others see the data in the survey123 website?

i already test if the feature is created in the datastore of the Enterprise Portal the users see the data. (one thing that notice is that when the S123website create the stakeholder view dont make the share to the group. i need to manualy do the share)

Is this configuration supported? Are the developers tested this configuration?

thanks.

Reply
0 Kudos