S123 Feature Report Template removing CR/LF in a textbox field

201
1
Jump to solution
02-11-2022 08:48 AM
FayGlunt
New Contributor III

Hello, Survey123 Gurus.  I am hoping you can help me with this issue we are having.  In our Survey123 App on Apple iPads (v 3.13.246), we have a textbox question of 1000 characters into which our users enter information that they format somewhat with carriage returns and line feeds to make it easy to read.  This then is saved as entered in our feature layer database.  But, when we bring the information into our feature report, it removes all carriage returns and linefeeds, smashing all the words together.  Have any of you encountered this?  Do you know how we can get the information to come into the feature report exactly as it is stored in the database?  I have included screenshots in the attachments below.  I just blurred the words for security reasons.  Thanks in advance for the assistance.  

0 Kudos
1 Solution

Accepted Solutions
FayGlunt
New Contributor III

Hi, All.  We figured it out.  We needed to use the Appearance method with the multiline parameter.  

It looks like this:  

${jobstory | appearance: ”multiline”}

https://doc.arcgis.com/en/survey123/browser/analyze-results/featurereporttemplates.htm

View solution in original post

0 Kudos
1 Reply
FayGlunt
New Contributor III

Hi, All.  We figured it out.  We needed to use the Appearance method with the multiline parameter.  

It looks like this:  

${jobstory | appearance: ”multiline”}

https://doc.arcgis.com/en/survey123/browser/analyze-results/featurereporttemplates.htm

0 Kudos