Select to view content in your preferred language

S123 Connect Performance is Poor

1152
13
Jump to solution
03-29-2023 02:48 PM
LydiaWerner_MAC
New Contributor III

Has anyone had issues with the performance in S123 Connect being poor? I have experienced it taking a considerable amount for the app to launch, the app crashing while in a survey form, or running other routine tasks. I have a fairly high performance desktop, so all the culprits such as RAM, CPU, etc., aren't indicating an issue.

TIA!

1 Solution

Accepted Solutions
ChristopherCounsell
MVP Regular Contributor

I'd always recommend specifying the version, it really does help.

I the end we can offer a few suggestions:

  •  Survey123 Connect version (apparently not)
  • Survey forms (does not sound like it)
  • Broader issues (none appear to be reported by other users)
  • PC (you have ruled out, and the app itself is light)

The last two things you can investigate are tied to network traffic:

  • Where is the Survey123 Connect content directory? Is it your local drive or have you tried to place it on a network? Is it on a OneDrive or something?
  • What is your internet/network environment like? Is Survey123 Connect slow if you connect to a different WiFi? Do you have antivirus running? Is your IT security tight?

 

 

View solution in original post

0 Kudos
13 Replies
rsun_TQB
Occasional Contributor III

Hi @LydiaWerner_MAC ,

Yes, but not all surveys will have poor performance on Survey123 Connect. We add the 4000ish addresses for one of text field for autocomplete purpose. It sometime was extremely slow when save and try to sync back to the Portal. 

Regards

0 Kudos
ChristopherCounsell
MVP Regular Contributor

This is most common with two things:

  • Surveys with a lot of calculations
  • Surveys with big lists. At some point (500 per list) you really want to move to external choice lists.

As @rsun_TQB mentioned 4000 choices = slow. They'll be created as domains. Better to push to a csv. See more on working with large lists here:

https://community.esri.com/t5/arcgis-survey123-blog/survey123-tricks-of-the-trade-external-choice/ba...

LydiaWerner_MAC
New Contributor III

@rsun_TQB & @ChristopherCounsell , I'm well aware of performance issues when you have large lists, etc. These are not  contributing factors at all for my surveys. As I said previously, the app takes forever to load, in addition to crashing at random times. 

0 Kudos
rsun_TQB
Occasional Contributor III

Hi @LydiaWerner_MAC ,

I would suggest contacting Esri support, and your IT department at the same time. 

If it's a global issue of Survey123 Connect being slow, Esri will treat it as high priority to fix this issue...but if it is not caused by the reason both @ChristopherCounsell and I talked about. It might be something going on with your Mac or PC or even network issues regarding VPN or internet speed. 

Hope the issue that you are facing will be resolved soon 🙂

 

0 Kudos
DougBrowning
MVP Esteemed Contributor

Are you on the latest version?  My Connect loads in 3-4 seconds.  I have forms 500+ lines and 10,000+ in the lists without issue.  It can be a clunky app at times but nothing major.  I get a few crashes a year maybe.  Are you installing it in a place besides C or anything like that?

LydiaWerner_MAC
New Contributor III

I'm running the most recent version, so that's not the issue. I can try installing it elsewhere, thanks for that idea.

0 Kudos
ChristopherCounsell
MVP Regular Contributor

What version of Survey123 Connect?

Is your internet stable? Anything going to stop the app communicating? Survey123 Connect leverages the survey123.com API.

0 Kudos
LydiaWerner_MAC
New Contributor III

I'm running the most recent version, so that's not the issue. Thanks.

0 Kudos
ChristopherCounsell
MVP Regular Contributor

I'd always recommend specifying the version, it really does help.

I the end we can offer a few suggestions:

  •  Survey123 Connect version (apparently not)
  • Survey forms (does not sound like it)
  • Broader issues (none appear to be reported by other users)
  • PC (you have ruled out, and the app itself is light)

The last two things you can investigate are tied to network traffic:

  • Where is the Survey123 Connect content directory? Is it your local drive or have you tried to place it on a network? Is it on a OneDrive or something?
  • What is your internet/network environment like? Is Survey123 Connect slow if you connect to a different WiFi? Do you have antivirus running? Is your IT security tight?

 

 

0 Kudos