Republished choice updates do not appear in feature layer

04-12-2017 12:48 AM
New Contributor III

I edited the choices to an existing survey and republished it successfully however these changes are not reflected in the feature layer in arcgis online.  What else do I need to do to see this change? (urgent!!)   The changes are available in the app but not online.

0 Kudos
23 Replies
by Anonymous User
Not applicable


I completed some testing on my end with adding new choices to my choices list for employees by simply adding Employee 1, Employee 2, Employee 3, to both my Choices list on the choices tab and within a comma delimited text file within the media survey and reposted the survey. I then refreshed my survey123 app, refreshed the Survey within the app, then tried some data entry within the form, the entries showed up and I used them for answers within the form and submitted the survey to the AGOL. I then downloaded the corresponding FGDB file that the form data was submitted to and the Employee 1, Employee 2, and Employee 3 answers should up within the FGDB within the data fields of the corresponding questions.

So, I went back and added in Employee 4 and Employee 5 as answers choices within the both of the areas that I had mentioned above, went through the same steps and the answers occur within the FGDB, but they do not appear within the Domains. Which for me is not a huge issue currently.

I thought I would let you and everyone else on the thread know. I figure that I can do an “update of the domain” after downloading in order to have the newly added choices within it if necessary. However, we are not completing any further updates on the data outside of the Survey123 post downloading from the Survey123 website.


New Contributor III

James Tedrick

I am also having this problem but with a hosted feature layer in Portal for ArcGIS and I tried to follow the instructions in the link you provided but I can't get the feature layer to give me the JSON. There is no option to "Update Layer Definition" instead there is an option to updateDefinition. 

When I click the "updateDefinition" all I get is:

{  "success": true }

Any suggestions?
0 Kudos
Esri Esteemed Contributor

Hi Rachel,

Yes, the text link itself states "Update Definition" though it's referred to as "Update Layer Definition" to distinguish the update operation at the layer level vs the update operation at the Feature Service level (which is "Update Feature Service Definition").

0 Kudos
New Contributor III


I go to this page:

And I click the "updateDefinition" button, and I get:

In the directions here: 

It appears I should have something like this:

I guess I am not understanding how to get the JSON for my feature layer in the first place in order to be able to modify the appropriate coded value domain.

0 Kudos