"The INSERT statement conflicted with the FOREIGN KEY constraint" Error

125
2
05-03-2021 09:33 AM
Taku_RiverTlingit
New Contributor II

Hello all,

my question/post related to https://community.esri.com/t5/arcgis-survey123-questions/quot-the-insert-statement-conflicted-with-t...  and https://community.esri.com/t5/arcgis-survey123-blog/st-kilda-penguin-release-3-1/bc-p/1051542

My apology for essentially triple posting - I just would really appreciate some help/advice/suggestions.

Here my problem again:

I still struggle with BUG-000117394 "The INSERT statement has conflicted with the FOREIGN KEY constraint" error (see attached screenshot).

I followed the following work flow:

  1. Create survey form in Survey123 Connect, have a GUID field with esri field type GUID
  2. Publish the survey form
  3. Create an empty point, line, and polygon feature class in AGOL.
  4. Download the survey feature class as well as the three other feature classes (point, line, polygon) and house in a geodatabase
  5. Make sure the point, line and polygon feature class has GlobalIDs and add unique Attribute indexes to it.
  6. Create three relationship classes between survey layer and each of the three other layers, where the point, line and polygon layer is the origin table, and the survey layer is the destination table based on GlobalID & GUID fields with 1:M.
  7. Upload the survey layer to AGOL - the three related feature layers get uploaded with it automatically.
  8. Add the survey layer to an editable web map - the three related feature layers get added to the map automatically.
  9. edit the pop-up of all three feature layers (point, line, polygon) and insert the survey form link&field:GUID={GlobalID). The survey link that can be found in "Collaborate" on the Survey123 website for the respective survey.
  10. Test the whole thing using ArcGIS Collector - I am accessing said web map, create a feature, e.g., using the point feature layer. Once feature is created, click on it to show pop-up, then click on survey link.
  11. Survey opens.
  12. Fill out survey & submit - but then attached error message appears.

 

I initially created the survey using Survey123 3.9, but I re-published using the latest version. Any ideas what I am doing wrong? One thing I am not entirely sure about is: I might have added the attribute index to the GlobalDs AFTER creating the relationship classes. would that matter at all?

Thanks a lot for the help.

 

Send Error.jpg

0 Kudos
2 Replies
DougBrowning
MVP Frequent Contributor

My advice would be to not use GlobalIds.  I use my own keys and it all works perfect.

See all of my reasons in this post.  https://community.esri.com/t5/arcgis-collector-questions/related-tables-for-offline-data-collection/...

Yes Esri says to use them, but in the real world there are lots of ways it fails.  Esp when moving data around.  Hope that helps.

0 Kudos
Taku_RiverTlingit
New Contributor II

Thanks a lot for that info - that's certainly good to know and keep in mind. I actually ended up just creating a GUID field in the survey for each point, line, and polygon layers, so that the relationship class could be set up on three fields instead of just one.

0 Kudos