"number" appearance keyboard not functionling properly in Survey123

710
5
03-15-2017 04:48 AM
Highlighted
New Contributor III

We have a form with a number field that we've given de "number" apprearance to get a numpad keyboard in the Survey123-app. Entering a value seems to go fine. However, if we try to submit the result of the form we get the following message: (which means "the field "afgelezen peilwaarde" is required")

bug message numpad in Survey123

If we enter a number through our default Apple iOS keyboard it submits just fine. It seems the numpad keyboard in the app isn't registering correctly.

Is this a known bug?  

We are using iPad Air 2's with iOS 10.2 and version 1.10.25 of the app.

Tags (1)
Reply
0 Kudos
5 Replies
Highlighted
Esri Regular Contributor

Hi Guido - I have tried to replicate this issue on the same device and Survey123 version. But no joy. Could you share your xls form with me so I can test it?

Thanks

John

Reply
0 Kudos
Highlighted
New Contributor III

Hi Johnathan,

I've uploaded the xls to this location. The Form in ArcGIS Online is located here.

Thanks for having a look.

Reply
0 Kudos
Highlighted
Esri Regular Contributor

Hi Guido

I have published your survey and was not able to replicate the behaviour that you are experiencing.

Could I ask that you log a support incident through: https://support.esri.com/contact-tech-support 

So that we can get some more thorough testing done.

Thanks

John

Reply
0 Kudos
Highlighted
Occasional Contributor III

Did you find out the issue?  This is happening to my survey as well.  The ios keyboard will pop up along with the "numbers" pad that S123 provides for user input.  Unless the "done" key is tapped on the ios keyboard, the field will not consider itself committed.

Reply
0 Kudos
Highlighted
Esri Regular Contributor

HI Erika - this is a different issue. We do have a bug open for the behavior you are seeing.

Reply
0 Kudos