Problems with Survey 123 - Pull Data

3155
17
03-15-2018 10:11 AM
AnthonyTaccone
New Contributor

I am having trouble implementing the pulldata function using Survey123. I have a CSV file that contains road names and the district associated with the road. That CSV has been put into the media folder of my survey. I believe my calculation formula is correct. When I go into my survey, the district simply doesn't populate or return any value. Any help would be appreciated. A screenshot been added below.

0 Kudos
17 Replies
JamesTedrick
Esri Esteemed Contributor

Hi Leydi,

The CSV file works for me.  Just to confirm, you are placing the csv file in the media folder of the survey?

0 Kudos
LeydiRamos1
New Contributor

Thanks for trying it.

Yes, the file that I passed to you is exactly the one in the media folder.

I have the Survey123 Connect 3.0.127, this will have something to do?

0 Kudos
JamesTedrick
Esri Esteemed Contributor

Hi Leydi,

The version of Survey123 Connect should not be affecting it (in fact, I'm using that version as well).  I've attached the version working on my computer.

0 Kudos
LeydiRamos1
New Contributor

Hi James!

I can not find what is different between the version you send me and the one I had, but using yours the pulldata works well. I replicated the same in other test forms and they also work perfect.

Thank you very much for the help!

0 Kudos
IslamSaeed1
New Contributor

Hello James,

I am facing an issue with Pull data function from a CSV with Arabic data and we entirely depend on this setting on our currently running project so i will be grateful if there any resolution/workaround to be able to pull Arabic values from CSV files

i am using ArcGIS Enterprise 10.7.1 and survey 123 connect 3.6

0 Kudos
JamesTedrick
Esri Esteemed Contributor

Note: I followed up with Islam off-line on this - the issue is the conversion from Excel creating non-UTF-8 CSV files.

0 Kudos
JanelleLeza
New Contributor II

I am also having this problem, the live survey shows the options that my pull data labeled, however it does not auto populate. One reason is I think that my list in choices nay not be correct. 

I am unable to share the data specifically so I left the screen shots as generic as I could

Is this the correct save file name that is in the media file?

This is how its saved, Is that okay?

0 Kudos
LebogangMashishi2
New Contributor II

Hi All,

Jumping in with a different issue. I am wondering if you are able to utilise the pulldata function for a survey you created in connect but are viewing on a web browser?

Your help will be appreciated.

0 Kudos