Problems with Attachments on iOS Devices with Survey123 v. 2.4.72

712
10
11-02-2017 12:37 PM
Highlighted
New Contributor III

Hello,

We are experiencing some odd behavior with attachments with version 2.4.72 of Survey123. When our field crew tries to add a photo from their iPad, only the link to the photo displays (not the photo itself). When the form is uploaded, the attachment is missing. If a new photo is taken from Survey123, it uploads without issue. 

Any ideas as to what might be the source of the problem?

Thank you,

Brittney

Reply
0 Kudos
10 Replies
Highlighted
Esri Regular Contributor

Hi Brittney


Please can you provide some more information on the device you are using - model and IOS version?

Thanks

John

Reply
0 Kudos
Highlighted
New Contributor III

Hi Johnathan,

Thanks very much for your reply. I believe the field staff is using iPad Air devices and they are on iOS version 11.0.3. They were able to add pictures from the camera roll before updating to Survey123 version 2.4.72. The survey itself was created with an older version of Survey123 (2.3.x)

I have an older iPad that is maxed out at iOS 9.3.5 that is running Survey123 version 2.4.72 and I am able to successfully add pictures from the camera roll.

Thanks very much for any insight you can provide. 

Brittney

Reply
0 Kudos
Highlighted
Esri Regular Contributor

Hi Brittney

IOS 11 uses a new image format (HEIC) that Survey123 does not currently support. The user will need to update their device settings to disable HEIC. This will force iOS 11 to store all images as JPEG. You can disable HEIC from settings > camera > formats.

Thanks

John

Highlighted
New Contributor

Hi Johnathan, 

I have the same problem as the one described in this topic. I do have an iPhone 6s with iOS 12.0 and tried to disable HEIC but I don't have the option to disable this in my settings > camera > formats.

Thanks in advance!

Iris

Reply
0 Kudos
Highlighted
Esri Regular Contributor

Hi Iris - select Most Compatible as the option.

Reply
0 Kudos
Highlighted
New Contributor

Where can I find this option?

Reply
0 Kudos
Highlighted
Esri Regular Contributor

Hi Iris,

I don't think that iPhone 6 would support HEIC/HEIF format, which is likely why you are not seeing the option to disable it.    For reference....Using HEIF or HEVC media on Apple devices - Apple Support

Have the pictures that you are attempting to upload in the field app been taken with the iPhone 6 native camera, or are you accessing them from somewhere else?  Please try to confirm what format the photos that you are uploading are in.

Thanks,

Brandon

Reply
0 Kudos
Highlighted
New Contributor

Hi Brandon, 

I tried different pictures: ones that have been taken by the iPhone 6 itself, ones I received by others and screenshots but they all don't upload in the survey.

Reply
0 Kudos
Highlighted
Esri Regular Contributor

Which version of the Survey123 field app are you using on your iPhone?  Does the same behavior occur in multiple surveys? 

Can you please try to create a brand new survey using the latest version of Suvey123 Connect, with one image question, and see if the issue is still encountered when attempting to upload a photo?  Also, what happens when you try to take a picture within the Survey123 field app?

Thanks,

Brandon

Reply
0 Kudos