Problem with results Survey123 inside ArcGIS Online

97
1
11-03-2018 08:52 AM
Highlighted
New Contributor III

I have a question related to Survey123 and ArcGIS Online.

I made a survey whereby one of the questions is 'Relevant voor leerstofonderdeel' (relevant for subject).

Therefore I choose inside Survey123 for a Single choice question (as only 1 answer allowed). 
See screenshot how it looked like in developing on the web.

screenshot of developing the question on the web.

When answering the question - as well in the app as on the computer the choices I made are maintained - I can see them and choose the one I want.

Bit when I look in ArcGIS Online there is a problem.

I choose for visualisation of the points that are added via the survey having each their own colour - and also in the legend it is visible, but when I click in the map on a point instead of the name of the choice I see 'Choice 2' - see screenshot or try for yourself on the map: https://arcg.is/1iae05.

inside ArcGIS online when clicking on a dot it doesn

Also when I want to filter on 'relevant voor leerstofonderdeel' it shows only a list with 'choice 1' up to 'choice 11' instead of the names I entered (like 'bevolking', 'geopolitiek') - see screenshot.

Also when filtering the same problem occurs

Anyone an idea how to resolve this?

Luc

Reply
0 Kudos
1 Reply
Highlighted
Esri Esteemed Contributor

Hi Luc,

When Survey123 creates a single choice question, it creates a domain that has the choices you typed in as the label and, by default, 'choice0', 'choice1' as the values stored (these can be changed at the time you publish the form through the 'Modify Schema' link).  As a workaround, you can use the Arcade expression arcade-expressions/label_Survey123_multiple_choice.md at master · Esri/arcade-expressions · GitHub  to construct a visualization with the labels.

Reply
0 Kudos