Primary Key Field Gets Automatically Populated with GlobalID

218
8
01-22-2019 11:32 AM
Highlighted
Occasional Contributor II

I have a feature service and a related table linked by a text field (hosted on AGO).  I understand that global ID - guid link is ideal for creating relationship classes, but this was unavoidable for the project.  I am opening the S123 from URL with the primary key field pre-populated with string value.  It is set as read-only in S123

I am able to successfully submit the survey.  However, the feature point created via S123 submission shows a global ID in the primary key field (UNIQUE_ID field) below.  

Am I trying to do something unsupported by S123 here?  Should relationships be created using only GlobalID-GUID fields?  

Reply
0 Kudos
8 Replies
Highlighted
Occasional Contributor II

Addendum: This only happens with web form (works as it should if data is submitted from native app).

Reply
0 Kudos
Highlighted
Esri Esteemed Contributor

Hi Ahjung,

Could you share the form?

Reply
0 Kudos
Highlighted
Occasional Contributor II

Hi James,

Here is an example URL. Thanks for looking into this! 

https://survey123.arcgis.com/share/11f6d9d548964793873bcb44eda0bbc9?field:UNIQUE_ID=somevalue

Reply
0 Kudos
Highlighted
Esri Esteemed Contributor

Hi Ahjung,

I've been able to replicate the problem and have filed an issue to resolve it.

Highlighted
Occasional Contributor II

Thank you for confirming that James.  Would you mind giving me the bug number?  I have a support ticket open, so I would like to link the case to the bug number so I can be notified when resolved.  

Reply
0 Kudos
Highlighted
Esri Esteemed Contributor

Hi,

Support will be generating a BUG- number soon (I work on Survey123 directly, and thus skip the support interface).

Highlighted
Esri Regular Contributor

Hi Ahjung

The bug number for this issue is BUG-000119623.

Kind regards,

Jim

Reply
0 Kudos
Highlighted
Esri Contributor

Hi Ahjung,

Thanks for the feedback. This bug has been fixed internally and will be out in our next version 3.5 release at end of June. Would you please have a try then?

Thanks and best regards,

Jody Zheng Liu