Portions of data hidden

278
4
06-15-2020 08:32 AM
New Contributor II

Hello,

I have a situation that I cannot seem to figure out. For some reason, a portion of the data collected using a Survey123 remains hidden from my compadres within my organization. Contained within the survey is an address question. When I view the results of the completed survey, in the Survey123.arcgis.com portal, I am able to see the submitted data for the address question. When other members of the organization attempt to review the results of the address question, they are unable to see the results. Matter-of-fact the question its self does not appear to be part of the form for them when viewing the data. I certainly have the collaborate settings set properly, as the members can view the survey and the submitted results; only the address question remains elusive. This is causing much confusion within the organization. Any solutions would greatly be appreciated. 

Thanks

Joseph Kelly

Reply
0 Kudos
4 Replies
Esri Contributor

Hi Joseph,

If you are referring to the geopoint question, I would use pulldata() to extract the information.

https://community.esri.com/groups/survey123/blog/2016/11/03/extracting-information-from-geopoint-que... 

Cheers,

Sun

Reply
0 Kudos
New Contributor II

Hello Jing,

 No, I am not referencing a geo-point question that would require a pulldata() function in the xlsform. The question is a simple text question on the form. The issue is after the form has already been filled out and submitted by the fieldworker. The issue occurs when organizational members, other than myself, attempt to view the information (data) that has been submitted by the fieldworker, and only for the specific "what is the address of the location?" question. I personally do not have an issue seeing the submitted answer to the specific question. It is only other members of the organization that have this issue. The question and answer, submitted by the fieldworker, does not appear (in the data tab of the Survey123 portal) for them to view, though the rest of the completed and submitted (by the fieldworker) survey is viewable. None of this is an issue when I attempt to view the completed and submitted surveys (in the Survey123 portal); only for other members of the organization.

Thanks

Joseph Kelly

Reply
0 Kudos
Esri Contributor

Hello Joseph,

Was this question added to the published survey after it was shared with the groups? 

Since the survey has been shared with groups, you and the others are looking at different feature services (views).

I guess this is similar to what you are seeing:

Problem: Survey results are not updated in Survey123 for ArcGIS 

Cheers,

Sun

Reply
0 Kudos
New Contributor II

Goodmorning Jing, 

The example from the link that you provided, seems to be exactly what I am experiencing! I will see if the workaround works, later this afternoon as all the tablets are in the field right now, and the workaround requires that the older version of the survey form, in the field app, gets deleted and re-downloaded.

Thank you for this, I hope it works. 

Thank you

Joseph Kelly

Reply
0 Kudos