MS Power Automate Flow not running when Survey123 submitted

275
3
06-30-2020 07:09 AM
Wade_Bryan
New Contributor II

I set up an automate flow using Microsoft Power Automate. 

The Flow shows up in the webhooks for the survey.

When the survey is submitted the flow is not being triggered. The flow is supposed to create an item in a list in Sharepoint as see above. Any ideas as to why the flow would not be triggered?

0 Kudos
3 Replies
Egge-JanPollé1
MVP Regular Contributor

Hi Wade, Bryan‌,

I am not sure, but I ha a similar issue sometime ago: MS Flow does not run when Survey123 response is submitted (At that time MS Power Automate was still called MS Flow...)

My issue was solved after downloading the survey again:

However, in this section I also found a link to additional documentation Webhooks—Survey123 for ArcGIS | ArcGIS with a brilliant remark:

Note:

If the survey you apply a webhook to has already been downloaded in the Survey123 field app, it will need to be downloaded again for the webhook to work.

Does this solve your issue?

BR,

Egge-Jan

0 Kudos
Wade_Bryan
New Contributor II

Hi Egge-Jan,

I appreciate your response and I tried that after creating the flow. Unfortunately it did not solve the problem.

Bryan

0 Kudos
SFM_TravisBott
New Contributor III

For what it's worth I've experienced similar issues with Power Automate and Survey123. I have surveys whose triggers worked just fine when I tested them, then suddenly stopped. 

There are threads on here about the need to repair your AGOL connection in order for it to keep working, but that defeats the purpose a bit of automating. 

0 Kudos