Microsoft Flow notification - two surveys one feature service

146
5
03-28-2019 03:44 PM
Highlighted
Occasional Contributor II

 Hi,

I have published a full survey (for Office use ) which contains all the details and by using the same feature service I have created another modified survey (for field use)which can be used in a field. I have set up notification by using Microsoft flow on a field survey - that's where we want the notification received once a survey completed. But when I submit a survey in my Inbox I received two notification email. 

I have only created one webhook for field survey but not sure why I am receiving two emails. Any help much appreciated.

Thanks,

Anu

Reply
0 Kudos
5 Replies
Highlighted
Esri Regular Contributor

Hi Anu

Would it be possible to provide a screenshot of your flow? Does your flow include any conditions or controls that might cause the email notification to be triggered twice?

Thanks & regards,

Jim

Reply
0 Kudos
Highlighted
Occasional Contributor II

Hi Jim,

I do have set up a condition using one field saying that depending on the Injury treatment send an email. Below is the snapshot.

Reply
0 Kudos
Highlighted
Occasional Contributor II

Hi Jim,

FYI,

I have just finished creating a new flow from scratch and seems that's working fine. 

Anu

Reply
0 Kudos
Highlighted
Esri Regular Contributor

Hi Anu

Thanks for the update. Sounds like there must have been something in your original flow that was causing the problem; great to hear it's working now. If you have any further issues please let me know.

Kind regards,

Jim

Reply
0 Kudos
Highlighted
Occasional Contributor II

Thanks Jim, will do

Reply
0 Kudos