Map Extent Survey123

957
7
03-04-2021 02:25 AM
com
by
New Contributor II

I have created a survey in Survey123 that includes a map. After publishing the survey, I previewed it and the map extent looks like how I have set it. However, when I have shared the map with users the map is zoomed out and not showing the extent that I had set when creating my survey.  The map appears correct for me but each user is getting different map extents when they open the survey.  Is there a way to make sure that the map appears with the correct map extent. Thanks.

7 Replies
Philip-Wilson
Esri Frequent Contributor

Hi @com,

Can you please provide a little more info. For example are you publishing with Connect or the web designer?

If you are using Connect what version are you using? And and the users completing the survey in the field app or web app? If field app what version?

What extent and zoom level have you set the map question to?

Regards,

Phil.

0 Kudos
com
by
New Contributor II

Hi Phil - I created and published the survey using the web designer - so I could not see the settings for the extent and zoom level. I have since opened the survey in Connect and set the map extent to lat. 53.28755 and long -6.24219 and the zoom level to 15. I used Streets as the basemap. I then published the survey. Now when the users open the survey they see the correct extent and zoom level but the basemap is now showing up as Imagery. I've attached 2 screen captures - one of what the survey map looks like in Connect and one of what the survey map looks like when opened in the web app. The users are opening up the survey via the web app - as this survey is meant to be opened by the public who wouldn't necessarily have the field app on their phone/tablet. The other issue I'm having is that the pin is no longer appearing in my map although it does appear in the preview map in Connect. I'm using the latest version of Connect as I just downloaded and installed it a few weeks ago. Thanks in advance for your help. Cynthia

0 Kudos
Philip-Wilson
Esri Frequent Contributor

Hi @com,

Thanks for the additional information, I will pass this issue onto our web team, and they will take a look and get back to you.

Regards,

Phil.

0 Kudos
ZhifangWang
Esri Regular Contributor

Hi @com ,

Thanks for attaching the screenshots, they help us to understand the issue.

 

  • For the default map displayed in the web app: did you set it explicitly in Survey123 Connect before publishing or just set the zoom level and lat/long in the Map tab but without clicking a map in the basemap gallery? To set a default map for the web map, you need either explicitly set a map in the "Select a basemap" dialog in the Map tab in Survey123 Connect (this sets the value in the displayInfo section in the .info file) or set a value "map=<itemID>" in the body::esri:style column in the XLSForm file. Otherwise, the web app will use the org's default map (could be Imagery in your case). Survey123 Connect by default uses the World Street Map if you don't touch any setting about the map.
  • The pin icon on the map: in the Survey123 web app, a pin icon on the map represents the real value of the geopoint question. If you want to see the pin on the map when opening the survey, it means you need to set a default value (in the default column in the XLSForm file) for the geopoint question. Otherwise, it is expected that there is no pin icon (default value) on the map by default.
0 Kudos
com
by
New Contributor II

Hi - thank you for following up with me. I set the default map explicitly in Survey123 Connect before publishing - I chose the map Streets from the basemap gallery. What should be the default value for the pin icon in the XLSForm file?  

Thanks, Cynthia

0 Kudos
ZhifangWang
Esri Regular Contributor

Hi @com ,

  • For the default value for a geopoint question: you can try "<latitude> <longitude>" in the "default" column in the XLSForm file. For example: "-37.814552 144.966071" . You can find more details in this help topic.
  • For the default map: since you mentioned the survey is shared with the public, would you mind sharing the survey URL so I can take a look (you can also send a direct message to me)? Or you can check the displayInfo section in the .info file of your survey to see if there is any similar setting to the green box in the attached image, this ensures the web app uses the World Street Map.
Andreea_Florea1
New Contributor

I have a similar issue, but the extent is showing incorrectly only on iPhones. In my case I published the survey through the web designer. Is there something that can be done in this situation?

0 Kudos