Select to view content in your preferred language

Login to ArcGIS online using a profile keeps asking to delete profile since it is v1.3 format

03-24-2020 07:28 PM
Occasional Contributor

I am wondering why from time to time that the login into ArcGIS using a profile keeps asking to delete it since it "appears to be in the <v1.3 format....  . This is not nice, I did not ask it to be v1.3.  Infact when the profile script is run, it says it is version 7.4!  I upgraded to 1.8 and now I turned back to 1.6.2 . What is wrong here?

Please see the image below and help me figure out what version it is talking about.  The API version 1.6+ the ArcPro installed is 2.4.3 and I have updated python 3.6 (it is the compatible version for ArcPro) . 

I use a script to set the profile as detailed in using authenticated profiles. Working with different authentication schemes | ArcGIS for Developers  

Why is this error coming up?

0 Kudos
4 Replies
Esri Esteemed Contributor

Hi Maaza,

It looks like this might be better asked in ArcGIS Pro‌?

0 Kudos
New Contributor II

Hi James Tedrick, I don't think this has anything to do with ArcGIS Pro. I am experiencing the same issue.

Our client only has ArcGIS Online, no ArcGIS Pro or access to ArcPy (only ArcGIS API for Python) and long story short, I wrote a Python script that does basic ETL processes (gets data from their API, transforms and loads it into a Hosted Feature Layer in their AGOL account). I followed the approach here to set up a .arcgisprofile persisted profile for saving the credentials to their AGOL account on the local machine in windows credentials manager: 

  • To create the profile using Python (once off): 

gis = GIS(url="", username="something", password="something", profile="AGOL_prof"')

  • For the script to use the profile from then on onwards: 
gis = GIS(profile="AGOL_prof")

It worked fine for a few weeks, the python script was scheduled and the layer in AGOL was updated regularly with new data like it should.
After a windows update one night, we realised the layer wasn't being updated anymore and I saw this when I tried to run the script using Command Prompt:

I had to delete the profile and create it again. It worked for a day and then the same thing happened again. 
Hope this helps
Esri Esteemed Contributor

In that case, it sounds like it would be better asked in ArcGIS API for Python‌ - this was originally posted in the Survey123 group.

New Contributor II
0 Kudos