Location use overlay for 'Geo' based/Map questions in Survey123

698
12
Jump to solution
2 weeks ago
Adam_Coburn_NCC
New Contributor II

Hello all,

I am building a form in Survey123 Connect (version - 3.12.232) that involves the use of 'geo' type questions (GeoPoint, GeoTrace, and GeoShape).

For the form to be publicly published, my organisation require a notification type feature to be included which informs the submitter that these questions will attempt to obtain and use their location.

Forms which are created from the Survey123 Web Designer are able to include this in a very slick and stylish way. This is done via ticking/checking the 'Ask for device's location when opening this question' box that appears once the map widget has been added to the form (See attached image). 

My question is, can this be recreated in Survey123 Connect? 

Thanks in advance,

Adam

12 Replies
Philip-Wilson
Esri Frequent Contributor

Hi @Adam_Coburn_NCC,

Thanks for sending through the XLSForm. I can reproduce the issue testing with 3.12 prod web app. However when I test with the 3.13 beta web app, which was just updated yesterday with latest code base and fixes, the error no longer occurs.

Can you please test with https://survey123beta.arcgis.com/ and let us know if you still get the error, and if the rest of your form is working as expected. Just add the word 'beta' after survey123 into the web form sharing URL as above.

Regards,

Phil.

0 Kudos
ZhifangWang
Esri Regular Contributor

Hi @Adam_Coburn_NCC ,

Thanks for sharing the XLSForm with us.

 

  • The error message TypeError: Cannot read property 'previousElementSibling' of null is caused by applying a wrong calculation to an attachment question. In your case, it's the row 73 and 74. Removing the calculation for these two image questions could fix the issue.
  • In addition, there is known limitation that the multiline appearance does not work in the web app if you refer the question name in the count-selected function in the constraints column. It is also the row 73 and 74 in your XLSForm. Please use a period "." instead of the question name as a workaround, such as count-selected(.) < 3 (note you need the brackets around the period). 

 

Thanks,

Zhifang

Adam_Coburn_NCC
New Contributor II

Hi @Philip-Wilson 

I created and published a new form with no guidance_hints and still received the error message. As a side note in the form discussed above, when you close the error pop up and continue with the survey the guidance hints are there not ideally formatted (but as you say support of this is there yet)

I will send over the xlsform and images 

Thanks,

Adam

0 Kudos