Invalid geometry in Survey123 Feature Layer

257
4
11-09-2021 08:15 AM
Jordi-Monk-Developer
New Contributor III

Hello,

We have noticed that ALL the records in the Feature Layer created by Survey123, once exported as a file geodatabase, have invalid geometry ("incorrect ring ordering"). The issue described below does NOT happen if the data is exported in geoJSON format.

We have noticed this both when:

  • authoring a survey via Survey Connect.
  • and when authoring it via the web designer in AGOL.

The surveys contain a geoshape question (polygons - Vertex mode)

The images below correspond to an extremely simple survey created with the web designer. It just contains a geoshape question (polygons - Vertex mode):

 

SURVEY

S123 formS123 form

 

After having submitted 2 entries in the survey (via browser) , this is the HOSTED FEATURE LAYER:

Feature Layer DataFeature Layer Data

 

The hosted Feature Layer has been then exported as a FGDB, and loaded on ArcGIS Pro.

Then the tool 'CHECK GEOMETRY' has been executed over its single Feature Class. This is the result:

Feature Layer exported as fgdb and loaded onto ArcGIS ProFeature Layer exported as fgdb and loaded onto ArcGIS Pro

 

This error prevents correct labelling (and it may cause other issues we are unaware of at the moment).

 

Result of the execution of the CheckGeometry utilityResult of the execution of the CheckGeometry utility

 

Thank you, in advance.

4 Replies
ABishop
Regular Contributor III

Hello Jordi,

What version of ArcGIS Pro?

Amanda Bishop, GISP
0 Kudos
Jordi-Monk-Developer
New Contributor III

2.8.1

0 Kudos
ABishop
Regular Contributor III

Have you tried repairing the geometry?

Amanda Bishop, GISP
0 Kudos
Jordi-Monk-Developer
New Contributor III

Yes, Repair Geometry works, and fixes the geometry. Also, if the features are obtained through a Portal connection, NO invalid geometry errors are found. It somehow seems to be related with the "Export as a FGDB" in ArcGIS Online.

The issue might have the same root cause as the one reported here:
https://community.esri.com/t5/arcgis-online-questions/file-issue-after-downloading-from-arcgis-onlin...

0 Kudos