Image question w/annotate appearance fails on submit on portal?

149
1
01-21-2020 01:29 PM
RobStauder
New Contributor II

Hi all,

Wondering if anyone has run into this?

  1. In Survey123 Connect - create a new survey from the Advanced Template
  2. Open the XLSForm in Survey123 Connect
  3. Add a question - type = Image, name = img_annotate, Label = annotate me!, appearance = annotate
  4. Publish to portal/enterprise 10.7.1
  5. Access the web form version of this survey  - eg: https://survey123.arcgis.com/share/<item id thing>?portalUrl=https://someportal.com/portal 
  6. Click in the annotate me input box and upload a small image.
  7. Click submit - fails with The upload request returns this - {"error":{"code":403,"subcode":52,"message":"Error performing upload operation, File size or type not supported for this service","details":[]}}
  8. Republish the survey without the annotate appearance - now it works upon submit. Only, we don't have the option to annotate in the web form.

Any ideas what could be going on here? Workarounds?

Rob

Reply
0 Kudos
1 Reply
Shwu-jingJeng
Esri Regular Contributor

Hi Rob,

I was able to see the same behavior as you described using a portal to publish a survey contained annotate appearance image question.

I encourage you to submit this issue as a bug via Esri Support. Our Support team will assign an official bug number for your records. This number can be used to search for and subscribe to the bug on the Esri Support site. If the issue is reported by other customers it will be attached to the same bug report, which helps us assess the impact of the issue and prioritize it accordingly.

Thanks,