I had another survey I created with the web version of survey123 get corrupted due to some sort of known bug between web versions or something like that. I brought the form design in version 3.7 or Survey123 Connect, made edits, update etc and published t

152
3
04-18-2020 02:00 PM
JeffCarney
New Contributor III

I brought the form design in version 3.7 or Survey123 Connect, made edits, update etc and published the form with coded domain values set green which I believe has the values show up in data fields instead of the choice number. I entered a few test records and exported to excel and still had choice numbers in all the data fields. I republished and set the domain values off and got the same result. What is happening, what is the correct setting to produce actual choice selections and not choice numbers.I am viewing the data and map using the "manage in web app" selection. I also get a file export error when trying to export to excel but not csv. Thanks

0 Kudos
3 Replies
IsmaelChivite
Esri Notable Contributor

Hi Jeff. I am sorry to hear that your work in Survey123 designer was lost.

Understanding the issue you run into in more detail would help us diagnose the problem and potentially fix it, so others -or yourself- will not run into it again in the future.  If you have more details and would like to share them, please open an Esri Technical Support incident so an Esri analyst can go with you through the process and document it for the Esri development team to fix issues found.

From your description above, it looks like you are changing the choice lists in your XLSForm but your feature service domains remain the same after publishing. This is expected, because the geodatabase domains are created when you publish the survey for the first time.  Survey123 Connect does not update your feature service domains when you publish the survey. This is how the software is designed at the moment.

 I found this idea in GeoNet https://community.esri.com/ideas/17261 you may want to have a look and vote if you agree with it.

Generally, it is not a good idea to re-publish a survey authored in designer with Connect, particularly when you make schema changes. It is best to download the designer survey in Connect, make a copy of it, publish the copy as a new survey and delete the original designer survey to avoid confusion. When you publish the survey for the first time from Connect, your choices in the XLSForm will be converted into a geodatabase domain. Again, once that domain is created Connect will no longer touch the domain, even if you change the list in XLSForm.

0 Kudos
JeffCarney
New Contributor III

Thanks. I will review the document link and dig deeper.

0 Kudos
JeffCarney
New Contributor III

What if I were to recreate the survey in the web version now that the bug(s) that caused the problem have been fixed or I I read that somewhere and remove all the feature services associated with the various version of the form. Or remove the feature services and republish in 123 Connect? With fix the problem?

0 Kudos