I can't get predictive text and multiline text working at the same time on Survey123 on Android app.

745
4
01-07-2019 02:33 AM
Highlighted
New Contributor

Predictive text has been disabled on the Android Survey123 app by default. How do I get predictive text working for multiline text fields through the Survey design spreadsheet. At the moment, it seems to only be allowing 1 or the other to be enabled at a time. This is very frustrating for myself and the users.

Reply
0 Kudos
4 Replies
Highlighted
Esri Regular Contributor

Hi Robert,

Which version of Survey123 Connect and the Survey123 Field App are you using?  After specifying a value of 'multiline predictivetext' in the appearance column of a text question and publishing your survey, you should see both the multiline appearance and predictive text enabled on your Android device.

I confirmed this behavior to be working when publishing a survey using Survey123 Connect v. 3.1.126 and Survey123 Field App v.3.1.159 on a Samsung Galaxy S8 with Android 8.0.

Let us know what your results are after trying this out.

Best,

Brandon

Highlighted
New Contributor

Hi Brandon,

Thank you, I was using an old version Survey123 Connect and that was causing the issue. I upgraded to the latest version and that fixed the issue. Thanks very much.

Highlighted
New Contributor III

I have the same problem, I can't get predictive text and multiline text working at the same time on Survey123 on Android app. the value 'multiline predictivetext' isn't exist.... only 'multiline' or 'predictivetext', how could we combinate both values? I mean, I need multiline text and predictive text at the same time.

using Survey123 Connect v. 3.1.126 and Survey123 Field App v.3.1.159 

Reply
0 Kudos
Highlighted
Esri Regular Contributor

Hi Harold,

You may need to turn off the validation rules for that particular cell in order to allow for multiline predictive text to be entered as a value.  As mentioned here, you can quickly remove data validation for a cell, by selecting it, and then going to Data > Data Tools > Data Validation > Settings > Clear All.

Try this and let us know your results.