I am using the "Report (Beta)" feature to generate a report using a report template. However, the map image generated by ${geometry} is a map inset that is zoomed out to the scale of the entire planet… Is there a way to generate a more useful map with a m

353
18
04-12-2018 03:10 PM
SaraBrookeBenjamin
New Contributor

I am using the "Report (Beta)" feature to generate a report using a report template. However, the map image generated by ${geometry} is a map inset that is zoomed out to the scale of the entire planet (see page 2 of attached file)… Is there a way to generate a more useful map with a more local, zoomed-in scaling? Maybe 1:10,000 or 1:5,000?

Reply
0 Kudos
18 Replies
SaraBrookeBenjamin
New Contributor

PS- I already tried specifying the Zoom level in the form Map Settings and those are at the scale I want, but the problem is with the Report (Beta) output. 

I should also mention that this SAME Report template previously provided the local scale zoomed-in map that I am looking for but then when I tried reproducing the report today, it reverted to this larger scale...

Reply
0 Kudos
JamesTedrick
Esri Esteemed Contributor

Hi,

The issue with the website not respecting the map settings will be addressed in an update to the website early next week.  You can manually specify the desired scale by using the 'mapSettings' parameter in the template:

${location|mapSettings:"10df2279f9684e4a9f6a7f08febac2a9":250000}

The first parameter is the ID of a particular web map to use.  The second is the scale.  both are optional, so you can omit the id if you want:

${location|mapSettings::250000}

SaraBrookeBenjamin
New Contributor

Hmmm... Now I am getting this error: 

Reply
0 Kudos
JamesTedrick
Esri Esteemed Contributor

I see the same problem and have filed an issue to correct it.  In the meantime, you can get the id of ArcGIS base maps by going to http://www.arcgis.com/home/group.html?id=8cb0765d4f394cc097407068580188ad#overview and selecting your preferred basemap - it will be the end part of the item details URL.

Reply
0 Kudos
JamesTedrick
Esri Esteemed Contributor

The issue is that an empty string ('') must be used instead of an empty value:

${location|mapSettings:'':250000}

Similarly, a value of 0 must be used for the scale instead of leaving blank.  We'll update our public documentation to more accurately reflect the values needed.

SaraBrookeBenjamin
New Contributor

This does not seem to work either...? I get this message:

Reply
0 Kudos
SaraBrookeBenjamin
New Contributor

And when I try to specify the basemap, I get this error:

Reply
0 Kudos
JamesTedrick
Esri Esteemed Contributor

On specifying the basemap - it should be in quotes.  And contrary to my example above, double quotes are preferred ("" vs '').

Reply
0 Kudos
SaraBrookeBenjamin
New Contributor

With double quotes, I get this error:

Reply
0 Kudos