How to add photos taken from another device, say a under-water camera,to the data record on Survey123 webmap in ArcGIS Online?

97
6
02-13-2019 08:42 AM
Highlighted
New Contributor II

My customer would like to add pictures taken from him underground camera onto the data record that is stored on Survey123 in AGOL. How can this be done?

Reply
0 Kudos
6 Replies
Highlighted
Frequent Contributor II

Assuming you are offline.

A lot of these cameras have Bluetooth now.  You could Bluetooth file transfer to the tablet.

Maybe you are lucky and the camera uses a SDCard and you have a Samsung with a SDCard reader built in.  If not you can also buy external SDCard readers for tablets.

There is a slight chance you can use the camera cable and plug into the tablet.

If the tablet has a cell card and the camera has WiFi you could turn the tablet into a hotspot and connect to it.

Hope that helps.

Highlighted
New Contributor II

Thanks, Doug, for this prompt and helpful response!

How can this be accomplished in the AGOL environment which hosts the data records gathered using Survey123 app in the field?

Reply
0 Kudos
Highlighted
Frequent Contributor II

Depends if you want it in the same record as the Survey123 form.  Add a Photo question to the form.  When filling out the survey just leave it blank.  Then later the user could plug the camera in to the computer.  Go into a AGOL web map that has the Survey123 Feature Service in.  Click to get the popup of the feature then click Edit.  You will see a Add Attachment at the bottom.  Add it there.  All Survey123 does is enable attachments on the FS - then you can use it anywhere just like regular attachments.

You can also have a separate FC just for photos.

Reply
0 Kudos
Highlighted
New Contributor II

Thanks, Doug. You're amazing, with your lightning-fast response!

What is FS and FC, by the way?

Reply
0 Kudos
Highlighted
Frequent Contributor II

FS = Feature Service

FC = Feature Class

Reply
0 Kudos
Highlighted
Esri Frequent Contributor

Hi Doug/George,

Note that if you add the photos via AGO directly to the feature record, they will be added as an attachment to that record but they will not be associated with the image question in the survey. When images are added via the survey in the field app or web app, we apply a keyword to link the image to a specific question. That way when you view the individual record in the Survey123 website, or print a report via the Feature Report option with a custom template, the image can be associated and displayed under the correct question and placeholder in the template.

There are a few posts on this subject in GeoNet already, and some user have created Python scripts to update the keywords. See this example: Is there an easy way to update the keyword associated with an feature attachment? 

Phil.

Reply
0 Kudos