How do I hide a question and populate it with a default answer in the background in Connect 3.10?

1034
6
Jump to solution
09-11-2020 10:24 AM
MichaelWallace3
New Contributor III

I have several questions that have default answers that don't change or are calculated from previous questions. Currently in 3.9 or below I can't hide these questions by making them irrelevant and still populate the answer. During the UC Q&A about Survey123, I was told that i would be able to populate an answer for a hidden or irrelevant question? I would like to know how to do this now that I have the newest version of connect 3.10.

0 Kudos
1 Solution

Accepted Solutions
IsmaelChivite
Esri Frequent Contributor

Hi.This could be done in 3.10 using the body::esri:visible column. Please note that this column is not in the Survey123 Connect templates. You will need to add it manually.  The use of the column is not documented, or officially supported either, for now. While this was presented in the What's new in 3.10 Esri UC 2020 technical workshop as part of 3.10, the feature was not officially added in the final cut of the 3.10 release. This capability works in the field app but as of now consider it a Beta feature. Work is ongoing to eventually bring this feature into the web app.

If you would like to learn more about this, check our Early Adopter Program doc here. Hope it helps

View solution in original post

6 Replies
IsmaelChivite
Esri Frequent Contributor

Hi.This could be done in 3.10 using the body::esri:visible column. Please note that this column is not in the Survey123 Connect templates. You will need to add it manually.  The use of the column is not documented, or officially supported either, for now. While this was presented in the What's new in 3.10 Esri UC 2020 technical workshop as part of 3.10, the feature was not officially added in the final cut of the 3.10 release. This capability works in the field app but as of now consider it a Beta feature. Work is ongoing to eventually bring this feature into the web app.

If you would like to learn more about this, check our Early Adopter Program doc here. Hope it helps

View solution in original post

MichaelWallace3
New Contributor III

Thanks Ismael for the clarification and unofficial documentation. This is exactly what I was looking for. I may wait till this becomes official depending on my timeline for improvements. Its more a look and feel issue for me at the moment.

0 Kudos
DougBrowning
MVP Frequent Contributor

The hidden or calculate types may work for you also if they always do not show.


Hope that helps

MichaelWallace3
New Contributor III

Thanks Doug, I have done that in other forms but this form must enforce domains.

0 Kudos
DougBrowning
MVP Frequent Contributor

If they are calculated fields with no user input it could not be wrong as a domain.  Maybe I am missing something here?

0 Kudos
MichaelWallace3
New Contributor III

I guess I just need to try calculating the domain value for a field and see if it honors the domains. I just wary of doing this because of previous experience. 

0 Kudos