How do I accurately record the end time for a survey using survey123 connect?

381
6
10-29-2020 01:41 PM
JoelDemory
New Contributor

I am using both 'start' and 'end' field types at the beginning of my survey. When I look at my data after a submission both start and end times are exactly the same. Both appear to be recording the start time. I attached a few screen shots. In the attached instance I waited over 5 minutes before submitting my test survey to make sure I wasn't submitting in the same minute.

0 Kudos
6 Replies
Shwu-jingJeng
Esri Regular Contributor

Hi Joel,

I can see the behavior you described in the latest build. We are looking into this issue and will get back to you shortly.

0 Kudos
Shwu-jingJeng
Esri Regular Contributor

Hi Joel,

Could you confirm that the survey which did not honor the end time is the web form only?

I could only reproduce this with web form but not in the field app.

if you use field app to submit the survey, both start and end time are honored as expected.

0 Kudos
JoelDemory
New Contributor

Hi, 

I can confirm that my survey did not honor the end time in the web form only. I just tried it in the field app for ios and the end time is honored. Unfortunately, I plan on using my survey in the web form. Do you know of a work around for this error to capture the end of the survey or an end 'stamp' that could be submitted as the last question?

Thank you

0 Kudos
Shwu-jingJeng
Esri Regular Contributor

Hi Joel,

Thanks for confirming the behavior and we will need to look into the web form issue for the end time. In the meantime, please use the field app as a temperary workaround and we will get back to you shortly.

0 Kudos
Shwu-jingJeng
Esri Regular Contributor

Hi Joel,

We had looked into this issue and found out it's a regression issue with 3.11 version of the web application and had logged an internal issue to fix this in the next release.

If you see a need to track this fix, I would encourage you to submit this issue as a bug via Esri Support. Our Support team will assign an official bug number for your records. This number can be used to search for and subscribe to the bug on the Esri Support site. If the issue is reported by other customers it will be attached to the same bug report, which helps us assess the impact of the issue and prioritize it accordingly.

Thanks for reporting this.

0 Kudos
Ruth_JiatengXu
Esri Contributor

Hi Joel,

Thanks for raising the issue here. The issue you raised has been fixed on the Survey123 website.

Thanks,

Ruth

0 Kudos