Help with accessing Survey123 Connect

09-30-2019 02:18 PM
New Contributor


I am trying to use Survey123 Connect, and am having trouble accessing anything.  I downloaded the desktop app, signed in and can see surveys I created on the web survey builder.

However, I cannot download any of my surveys or any of the templates/examples/samples.  When I  download an item (my survey, templates, examples), it just hangs.  The Downloading window appears, but it just spins endlessly.

I have been able to author a brand new form, but would like to take advantage of the templates/examples.

Any ideas what is hanging me up?

Are there any alternative locations for downloading the XLXS advanced/basic templates?



0 Kudos
5 Replies
New Contributor

If it helps, here's a screen shot of what I am looking at,  I also have full admin rights, no firewall issues, am running the latest version of Survey123 Connect, and I have also tried Survey123 Connect Classic with the same results.  I'm using Windows 10, on a 64bit OS.

Thanks - I appreciate any ideas anyone may have!


0 Kudos
Esri Contributor

Hi Amy,

Please have a look at this page: Cannot download any surveys in Survey123 Connect

Phil mentioned that 

Survey123 Connect will not run correctly if installed to C:\Program Files\


the default and correct location is: C:\Users\{username}\Applications\ArcGIS\Survey123ConnectforArcGIS\

Maybe this could be the reason.

If this is not the case, could you turn on [Logging] under [Diagnostics] in the settings? Then you might be able to tell whether that's a server issue or local issue by interpreting the log file.



0 Kudos
New Contributor II

Make sure that the (1) the survey is published, (2) that it has been shared to your group or shared to the public, (3) that the "Submitter" section under the "Collaborate" tab has also been updated to reflect who can submit to the survey. the last step may be the cause of the error you are seeing. My users were also showing that error. survey123 design #collaborate #submitter

0 Kudos
Esri Esteemed Contributor

The Advanced template can be downloaded at 

As a workaround, you could rename the file to the name of the survey you wish to create, and then drag it into Survey123 Connect.

0 Kudos
New Contributor

Problem solved!

The problem lies somewhere in our security services division settings... we tested it on other workstations with the same results.  But once I used a different device off of our network, everything worked fine.  I'm still not 100% clear what is going on with my network security settings, but am happy to have a workable option now.  Downloading the templates directly from AGOL worked fine too - I appreciate the links that you sent James.

Thank you all for your help!


0 Kudos