Forced update on S123 v 3.9 web form + gateway timeout

242
5
09-15-2021 02:26 AM
Dawn
by
New Contributor II

I came across this issue today for a survey embedded as a web form within a VUE js app:

"The webform needs to be upgraded, but an error occurred while upgrading." HTTP 504 Gateway timeout
 
The survey was published with Survery123Connect v. 3.9.120 to an ArcGIS Enterprise Portal and it appears that the survey123.arcgis.com api is "forcing" it to be upgraded to 3.12 and it is possible that the process timed out because of network speed.
 
dstalberg_2-1631697573837.png

 

The setting within the survey for forcing an update is turned off.

dstalberg_1-1631697396264.png

The only way to resolve the issue was to install S123Connect 3.12 and to republish the survey.

Is this a new "feature" of Survey123?

Is there anyway to stop survey123.arcgis.com from trying to force an upgrade while the user is trying to access the form? Is there another setting that can be modified?

0 Kudos
5 Replies
JamesTedrick
Esri Esteemed Contributor

Hi @Dawn ,

From your description, there's a bit of overlap in what 'upgrade'/'update' means. Upgrade refers to the version of Survey123 Connect/Survey123 website used to publish the form; update refers to re-publishing of the form.

The setting in Survey123 Connect is specific to requiring the Survey123 field app to require the user to use the latest version of the form that is published.  This is irrespective of the version of Survey123 Connect used to publish the form.  This is also pertains only to the field app and has no bearing on the web form.

You mentioned that the form is embedded in another application.  What is the embedding mechanism?  Are using the version=latest URL parameter to require the upgrade (it appears so based on the console log you provided)? 

The easiest way to resolve this would be to republish with the current version of Survey123 Connect.  With regard to the 504 error, it would be useful to open an Esri Support ticket to try to diagnose what is occurring.

Dawn
by
New Contributor II

Hi James

Thanks for the quick response.

The survey is imbedded in a VUE.js application

 const survey123WebForm = new Survey123WebForm({
                    container: "details-survey123-webform",
                    clientId: CONFIG.OAUTH_APP_CLIENTID,
                    portalUrl: CONFIG.PORTAL_URL,
                    itemId: CONFIG.CALL_DETAILS_ITEMID,
                    token: auth.getToken(),
                    hideElements: [
                        "navbar",
                        "footer",
                        "header",
                        "field:object_id",
                        "field:capture_user",
                        "field:capture_date",
                    ],
 
It does not explicitly include the parameter version=latest, so I suspect that 
https://survey123.arcgis.com/api/jsapi is appending that when he web form is called?
 
Is there any known incompatibility between the latest Survey123WebForm and S123 v 3.9 published forms?
 
As stated in the post, I have already resolved the issue by republishing with the latest version of S123Connect, but am interested to find out the underlying issue so that we can prevent it from happening with other surveys at other clients where they are using surveys published with an older version of S123Connect.
 
After republishing the form, there is no need for the form to be upgraded, so the Gateway error is not occurring. The system is of a time-critical nature, so it was not possible to wait for esri support in order to investigate the Gateway timeout error.
 
Just one other point to note - the problem only started to occur on 2021-09-15: on the day before, the survey loaded without any problems.
0 Kudos
JamesTedrick
Esri Esteemed Contributor

 @Dawn ,

 

Following up on the 504 issue, our server logs indicate that this may be something particular with your form (all of the occurrences of a 504 error for updateWebform in the past 3 days appear to be associated with one form).  I'm wondering if there are some aspects to the form that would cause the updateWebform processing to take a longer than allowed for time; one particular area that could cause this are a large number of choices in the form.  If you would like to, please follow up with me via e-mail (jtedrick AT esri.com) with the form so that we could further analyze this.

0 Kudos
JamesTedrick
Esri Esteemed Contributor

@Dawn,

In checking with the Survey123 web development team, the cause of the 504 in your situation (portal unreachable) was identified during 3.13 development and should be resolved with 3.13's release yesterday.

Dawn
by
New Contributor II

Thanks for the feedback James - I haven't upgraded to 3.13 yet as the 504 error has not reoccurred.

0 Kudos