Filling out a Survey123 form from Explorer

383
2
03-16-2019 12:25 PM
GrantHaynes
Occasional Contributor

I'm trying to launch and fill out parts of a survey123 form with attributes from a map service on Explorer, I've figured out most of it, but I'm having an issue where only one field in the survey is being filled out. It seems I'm doing everything right, but I can't get it to work right. I'm hoping someone here can help me out.

URL: arcgis-survey123://?itemID=6d45d37261524def90131c01fcae73d1&field:Well_Key={OBJECTID}&field:Project={Project}&field:Well_ID={Well_ID}&field:Well_Material={Casing_Material}&field:Casing_Diameter={Casing_Diameter}&field:Installed_Depth={Depth}&field:Screen_Height={Screen_Height}

Survey123 section to be filled out from attributes:

hiddenWell_KeyWell_Key
textProject<center><b>Project</b></center>
textWell_ID<center><b>Well ID</b></center>
dateSurvey_Date<Center><b>Date</b></center>
startSurvey_Start
endSurvey_End
select_one staffPersonel_PresentStaff
hiddenAuto_Stable_MeterAuto Stabling Meter?
begin groupWell_Construction<center><b>Well Construction</b></center>
select_one materialWell_MaterialWell Material
decimalCasing_DiameterCasing Diameter
decimalInstalled_DepthInstalled Depth
decimalScreen_HeightScreen Height

Feature Attributes:

Software:

Map Service hosted on Arcgis online, published from Arcmap 10.5

Survery123 form developed on survey123 connect v 3.3.51 on windows 7

forms tested on Samsung S7 android version 8

Tags (1)
0 Kudos
2 Replies
JohnathanHasthorpe
Esri Regular Contributor
0 Kudos
GrantHaynes
Occasional Contributor

I figured this out there was nothing wrong with the URLs, it was a refreshing issue.

0 Kudos