Favorite answers not filling relevant questions

235
3
Jump to solution
06-10-2022 07:36 AM
Polesig
New Contributor III

Hi,

Using Survey123 Connect 3.14.256 and survey123 Field App 3.14.255

When I set favorite answers on a survey and paste them on a new survey, the questions that are subject to a relevant formula are not filled in with my favorite answers.

If I paste my favorite aswers a second time, all fields are filled in according to what i saved as favorite.

Related to https://community.esri.com/t5/arcgis-survey123-questions/survey-123-favorites-answers-not-working-wi...

Has anything changed in a version that could cause this behaviour ? Or has it always been like this ?

Thank you !

0 Kudos
2 Solutions

Accepted Solutions
ZacharySutherby
Esri Regular Contributor

Hello @Polesig

This is a known issue on our end and we have an internal issue to fix it. The change came with a significant overhaul of how expressions are handled to better improve app stability with the 3.14 release. 

Please feel free to reach out to Esri Technical Support and they will be able to assist with attaching you to an official BUG to track the status of the issue. 

Thank you,
Zach

View solution in original post

0 Kudos
ZacharySutherby
Esri Regular Contributor

Hello @MFFPUSER

Unfortunately we don't have a timeline on the fix at this time. The issue has been logged as BUG-000150073, please feel free to reach out to Esri Technical Support and they will be able to attach you to the defect so you can track progress on the behavior. 

The workaround we've identified at this time is to select "Paste answers from favorites" a second time and that should populate the relevant questions. 

Thank you,
Zach

View solution in original post

0 Kudos
3 Replies
ZacharySutherby
Esri Regular Contributor

Hello @Polesig

This is a known issue on our end and we have an internal issue to fix it. The change came with a significant overhaul of how expressions are handled to better improve app stability with the 3.14 release. 

Please feel free to reach out to Esri Technical Support and they will be able to assist with attaching you to an official BUG to track the status of the issue. 

Thank you,
Zach
0 Kudos
MFFPUSER
New Contributor

Hi Zachary,

I'm new to Survey 123 so I'm not sure if this is the correct way to approach this issue. We too have the same issue with favourite answers not pasting into a new record. Is there an update on this fix please? We have the version Survey 123 Field App 3.15.146.

Thank you

0 Kudos
ZacharySutherby
Esri Regular Contributor

Hello @MFFPUSER

Unfortunately we don't have a timeline on the fix at this time. The issue has been logged as BUG-000150073, please feel free to reach out to Esri Technical Support and they will be able to attach you to the defect so you can track progress on the behavior. 

The workaround we've identified at this time is to select "Paste answers from favorites" a second time and that should populate the relevant questions. 

Thank you,
Zach
0 Kudos