Embedded Survey123 Web Form works for some but not others

1814
10
Jump to solution
04-01-2020 08:59 AM
MichaelBrown4
New Contributor III

I have a Survey123 Web Form embedded in Operations Dashboard with the Embedded Content widget.  It works great for 99% of my users, but I have a handful of users that the survey will not load for them in the Embedded Content widget.  It will load fine for them outside of Embedded Content.

I think this is probably a setting on the user's computer, but have not been able to diagnose it.  Has anyone come across this before?

Thanks in advance,

Mike

0 Kudos
1 Solution

Accepted Solutions
DSIProvince_Nord
New Contributor III

hi! Bug number is:

BUG-000129632: Signing in to the Survey123 surveys embedded in Operations Dashboards fails in Google Chrome 80.0.3987.149

To resolve the problem:

1. In Google Chrome, go to the address: chrome: // flags /.

2. Deactivate the "SameSite by default cookies" option.

3. Restart Chrome

View solution in original post

10 Replies
CharmelMenzel
Esri Contributor
0 Kudos
DSIProvince_Nord
New Contributor III

Hi, I have the same issue with some of my users.

Following Ismael's thread, I was able to embed Survey web form in a dashboard, and edit existing features using url parameters (i.e. &mode=edit&objectId={objectid}&version=latest).

Most of the time it works fine but sometimes the survey just doesn't appear at all (warning message like : Survey does not exist or is not available). Tested with up-to-date Chrome and FF browsers.

Maybe it is related to the use of ObjectID instead of GlobaID → See this post https://community.esri.com/groups/survey123/blog/2020/02/19/upcoming-changes-to-survey123-web-forms-... 

And be sure you update your dashboards within the next days to use GlobalIDs.

Regards

0 Kudos
MichaelBrown4
New Contributor III

This turned out to be due to the new Chrome update (80) and the SameSite security/cookie rules they are applying.  This is solved with ArcGIS Online hosted content, but apparently not with ArcGIS Enterprise.  For now, I found my users could get the embedded Survey123 web forms working again if they updated the Chrome settings as shown below.  Hope this helps others.

  1. Open Chrome Browser
  2. Go to Settings (under the 3 dots on top right corner)
  3. Click on Privacy and Security
  4. Go to ‘More’
  5. Toggle on ‘Preload pages for faster browsing and searching’.
  6. Close and relauch Chrome

chrome settings

ChrisRoberts2
Occasional Contributor II

We are seeing the same thing.  Unfortunately your workaround didn't work for us Michael. Tries clearing all history and cookies as well, also tried in an Incognito Window.

Using IE or the latest version of Edge the users can see the form. Just not in Chrome ... and again not all users are seeing this issue.

We are currently using Enterprise 10.7.1, will be upgrading to 10.8.1 in the next few weeks, hopefully that will resolve this?

0 Kudos
MichaelBrown4
New Contributor III

I'm seeing this again actually.  The method I described does fix it for some, others we have to wipe their entire Chrome user profile, then it works for a little while, then starts behaving the same way.

We're also on Enterprise 10.7.1.  I'm wondering if there is a configuration on the server or our authentication that needs to be changed?

0 Kudos
DSIProvince_Nord
New Contributor III

hi! Bug number is:

BUG-000129632: Signing in to the Survey123 surveys embedded in Operations Dashboards fails in Google Chrome 80.0.3987.149

To resolve the problem:

1. In Google Chrome, go to the address: chrome: // flags /.

2. Deactivate the "SameSite by default cookies" option.

3. Restart Chrome

View solution in original post

ChrisRoberts2
Occasional Contributor II

That worked!  Thanks muchly

MichaelBrown4
New Contributor III

Just tried this and worked for me as well.  I had read about the SameSite update to Chrome and also that Google was delaying it, totally forgot about this.  Thanks for the help!

RicciLucas
New Contributor II

That didn't work for me...by deactivating he meant disabling it, right? Anyway, the only workaround for this issue is to not use Chrome at all. It works fine on FF and edge.

0 Kudos