Embedded Survey123 form in Dashboard does not show select groups with a relevant statement

267
3
Jump to solution
04-02-2021 12:06 PM
cbolen
by
New Contributor II

I have a Survey123 form that I embedded into a Dashboard so the project team can review and sign-off on the data collected by the field inspectors.  There are a total of 16 inspection features across 8 ponds to be inspected. Each of the 16 inspection features has a list of questions and are organized as groups. Seven of the 16 inspection features are universal to all 8 ponds. The remaining 9 inspection feature groups are dependent on what zone is inspected and have a relevant function specified (e.g., selected($dam}). Thus, when a field inspector selects the pond to be inspected at the beginning of the form, they only see the relevant inspection features for that pond and not all 16. 

The problem: in the dashboard when the form is embedded, only the 7 universal inspection features show up and not any of the inspection features that have a relevant statement. S123 was created and published through Survey123 Connect, version 3.11.123.

What I have done to trouble shoot with no solution thus far.

1. Tested Dashboard vs Dashboard Beta

2. Created a simplified form with same basic logic (embedded form works just fine, just like on tablet and as designed with relevant statement and even repeats built in).

3. Deleted the existing relevant functions for each group in the form = shows up correctly in embedded element in dashboard, but obviously no longer being filtered by pond relevancy.

Any idea what is going on? This is an essential workflow for both field inspector and data reviewer.

Procedure in embedding form does not appear to be the issue but I did use the following links for reference. Again, seems to be isolated to the relevant statement.

 

0 Kudos
1 Solution

Accepted Solutions
cbolen
by
New Contributor II

Solution - removed spaces for select_one choice name in form, which fixed the issue (i.e., Pond B vs Pond_B). Space did not effect data collection in field app just when embedding into dashboard.

View solution in original post

0 Kudos
3 Replies
DougBrowning
MVP Frequent Contributor

You said this is just a sample but if you did copy/paste this you have 2 syntax issues.
selected($dam} should be selected(${dam}, valuelike selected(${question_one}, 'a')

Just making sure since it is just 1 you said.  Hope that is it.

CoryBolen1
New Contributor III

Hi Doug, Thanks for the response. I transcribed / typed what is in the form incorrectly into my post.  Below is an example with direct copy/paste from actual form. Form logic on tablet / field app works as intended for field crew, just not when embedding into dashboard. 

selected(${dam}, 'Pond B')

0 Kudos
cbolen
by
New Contributor II

Solution - removed spaces for select_one choice name in form, which fixed the issue (i.e., Pond B vs Pond_B). Space did not effect data collection in field app just when embedding into dashboard.

View solution in original post

0 Kudos