Editor tracking times converted incorrectly in ArcPro and data export

48
1
01-16-2020 04:57 PM
Highlighted
Occasional Contributor

Hi,

When a user submits a survey the feature service displays the Creation and Editor date/time correctly in AGO.  The data tab on the details page, the web map popups, and web app builder all display the date/time as the correct local time.  When the service is added to a map in ArcGIS Pro the time displays incorrectly.  It appears to be converting from UTC to Eastern local in Pro by adding 5 hours to the time.  This conversion also takes place when the data is exported to a gdb. These fields, being system managed, I believe are not editable.  Our department needs to migrate data collected in the hosted surveys to our Enterprise database on site and maintain the original editor tracking date/times.  If we use a credentialed service from our onsite ArcGIS server we lose the user who created or edited the data, since the credentialed server user is maintained in the dataset.

Any advice on how to maintain the original editor tracking times will be most appreciated.

Best,

Ed

Tags (4)
Reply
0 Kudos
1 Reply
Highlighted
Esri Esteemed Contributor

Hi Ed,

ArcGIS Online stores all time in UTC.  You can set the time zone as part of layer settings (if using the time for visualization), or convert the date displayed using a GP tool. I would suggest converting the time fields during the ETL process - you would need to temporarily disable the editor tracking fields anyway to preserve the editing username during the migration (which means you could recalculate the time data as well).

Reply
0 Kudos