Data from attached .csv not populating in survey form

266
5
03-02-2021 10:43 AM
BrianHenley
New Contributor

I am using a hosted feature layer in Field Maps to select a polygon of interest (which is configured to pop up a survey form and it works great!). In addition to the survey form (.xlsx), there is data attached from a .csv file (in the media folder) and is used as a reference in decision making on the form. The .csv file data is not populating in new downloads of my survey form. It is still populating on one tablet (see attached photo) and not on the others?  I used  the article posted  for reference on attaching: https://doc.arcgis.com/en/survey123/reference/integratewithotherapps.htm

Any suggestions?

It is possible that the issue starts with my .csv file reference field (which is a 14 digit number with a leading zero). I have formatted a few different ways, but may still be a problem.

 

0 Kudos
5 Replies
KPyne
by
New Contributor

I am having a similar issue, but I believe it has to do with the most recent Survey123 for iOS update. We have fields that calculate based on an external table, and they are no longer working in this version

0 Kudos
AndrewPadilla
New Contributor III

I am also have issues with pulldata function in multiple surveys. All worked prior to the latest update to Survey123 and iOS. I am working with ESRI to determine the issue and come up with a solution. My original post is here: https://community.esri.com/t5/arcgis-survey123-blog/what-s-new-in-arcgis-survey123-february-2021/bc-...

I will post any updates as they become available.

 

0 Kudos
KPyne
by
New Contributor

Thanks for the link Andrew, hopefully they figure out something quick. We have one mobile device that is on an earlier version of Survey123 and the csv is populating correctly. Keep us updated!

0 Kudos
AndrewPadilla
New Contributor III

Some folks have found solutions to the pulldata and select_one_from_file issues. See this post: https://community.esri.com/t5/arcgis-survey123-questions/survey123-version-3-12-274-pulldata-functio...

 

0 Kudos
KPyne
by
New Contributor

Awesome, I am still having issues despite the csv being in the correct format. I will go ahead and move my comments to that thread as it may be unrelated to this post. Thanks!

0 Kudos