Choice list not updating after publishing

722
14
07-21-2017 11:10 AM
Highlighted
Occasional Contributor III

I have a published survey that has a typo in a filtered choice list for one of my questions. I corrected the typo in Survey123 Connect and successfully published the change. However, the update does not appear in the (re)published survey.  

I have looked at the ArcGIS REST Admin Directory for the AGOL Hosted Feature Layer.  It does not show a domain for the field of interest.  

How do I change values in filtered choice lists so that those changes appear in the published survey?

Thank you.

Reply
0 Kudos
14 Replies
Highlighted
Esri Esteemed Contributor

Hi Tom,

What you describe should be the way to update the typo.  Just to be clear, you are not seeing the update in a app or web context?

Reply
0 Kudos
Highlighted
Occasional Contributor III

Hi James.  Thank you for your SUPER fast response.

Partially correct - I am not seeing the update in the Survey123 field app (I am not sure what you mean by web context). I open survey123, go to the 'download surveys' page and see that the 'updated' date matches my last publish time.  I then click the 'refresh cloud'. I see the downloading messages, then open the Survey.  The old choice data are still present.

What i just did, however, was to use Survey123 app to delete the survey from my local machine, then re-download the survey.  In that workflow, the new choice data are present.  So it seems that the 'refresh' function isn't really updating the existing data. You need to remove the previous data first and then get the new survey.

Reply
0 Kudos
Highlighted
Esri Esteemed Contributor

Thanks, I'll try to reproduce this.  It might also be agitation where the application has cached the information in memory- if I can reproduce I'll also try quitting and reopening the app.

Reply
0 Kudos
Highlighted
New Contributor III

I have a similar bug. I have a choice of field tech names. When I add names to that list in Survey123Connect, I get a successful publish to AGOL, and I see the added names in on the app. However, when i go on the desktop Survey123 for ArcGIS, the list of names was not updated. 

Reply
0 Kudos
Highlighted
Esri Esteemed Contributor

Hi Rene,

This is a known issue with Survey123 Connect - it currently does not update a domain after initial publishing.

Reply
0 Kudos
Highlighted
New Contributor III

Hi James, will future releases be addressing this or should I post it as an idea to vote up?

Reply
0 Kudos
Highlighted
Esri Esteemed Contributor

Hi Simon,

Esri support has the enhancement ENH-000106608 that you could ask to join your account to.  There is also Have an Option Where Survey123 Dropdown List and Domains are Synced

Reply
0 Kudos
Highlighted
Occasional Contributor II

Hi James,

Just wondering whats the status of this issue? Has it been resolved with new version?

My query is slightly different I also want to update new addresses to the choices list to the published and in use Survey. Can I add it without losing any data? 

Thanks,

Anu

Reply
0 Kudos
Highlighted
Esri Esteemed Contributor

Hi Anu, 

As my post above indicates, currently domains are not updated on republishing.  You can certainly add the values without losing data; the problem that occurs is that other applications may not show the values because it isn't part of the predefined list of acceptable values.