Can you configure the template or feature report to omit null fields?

984
7
Jump to solution
08-02-2019 07:49 AM
MikalaRandich1
New Contributor II

Hello,

I was wondering if you could configure the template in Survey123 or the feature report tool to omit fields from the report that have null or no response? 

Thanks for any assistance!

Mikala

1 Solution

Accepted Solutions
Jim-Moore
Esri Regular Contributor

Hi Mikala

You can use conditional statements in your feature report template to show or hide content. For example, to show a text question only if it has a value, you could use something like:

${if text_question!=""}
Text Question: ${text_question}
${/}‍‍‍‍‍‍‍‍‍

Please find details on conditional elements here: Feature report templates—Survey123 for ArcGIS | ArcGIS 

Hope this helps,

Jim

View solution in original post

7 Replies
Jim-Moore
Esri Regular Contributor

Hi Mikala

You can use conditional statements in your feature report template to show or hide content. For example, to show a text question only if it has a value, you could use something like:

${if text_question!=""}
Text Question: ${text_question}
${/}‍‍‍‍‍‍‍‍‍

Please find details on conditional elements here: Feature report templates—Survey123 for ArcGIS | ArcGIS 

Hope this helps,

Jim

View solution in original post

MikalaRandich1
New Contributor II

Thanks so much Jim, that worked! 

ToryChristensen
New Contributor III

Hi Jim,

Is there a way to avoid creating a new line for every question so that if it is blank, there will be no empty row created on the feature report? Thanks

Jim-Moore
Esri Regular Contributor

Hi Tory, thanks for your query, this is a known issue with conditional elements in a report template. If possible, could you please log this through Esri Support so we can add it to cases raised by other users? This helps us prioritise enhancements and fixes.

Best,

Jim

0 Kudos
KarolFallas
New Contributor II

Hi Jim,

Is there any news regarding the topic?

"Is there a way to avoid creating a new line for every question so that if it is blank"

Thanks.

0 Kudos
Jim-Moore
Esri Regular Contributor

Hi Karol, no update on this issue at this stage - it is still in our backlog; but as mentioned above, please feel free to report it through Esri Support so we can add your case to the issue.

Best regards,

Jim

0 Kudos
KarolFallas
New Contributor II

Thanks Jim,

I used:

${/} ${field1=="categoria"}

descripcion field1: ${field2}

descripcion field2 ${field3}

descripcion field2 ${field4}${/}

That worked for my workflow.

Best regards

Karol