Can't Login To Enterprise 10.7.1 Portal in Survey123 Mobile App

577
7
Jump to solution
12-31-2020 11:26 AM
LeviCecil
Occasional Contributor III

We have just configured an Enterprise 10.7.1 base deployment. We're using Field Maps with internal links to Survey123. We were able to register Field Maps with the Enterprise. When we try to login to Survey123 with our Portal URL https://exampleportal.esri.com/arcgis, we get the error "Survey123 requires a base ArcGIS Enterprise Deployment." If I try to sign in using the steps in this thread: https://survey123.arcgis.com/?portalUrl=https://exampleportal.esri.com/arcgis, then the app asks for certificates? We have 100 tablets that will be logging in to Field Maps and S123. Do we need to install certificates on all of them?? 

1 Solution

Accepted Solutions
LeviCecil
Occasional Contributor III

Our hosting contractor just figured it out. We just didn't have the datastore hosting configured yet.

View solution in original post

7 Replies
Shwu-jingJeng
Esri Regular Contributor

Hi Levi,

To connect to the portal from the field app on the mobile device, the mobile device needs to be connected to the same network which the portal is hosted. You may need to VPN to the network and conect to the portal. 

The connection to the portal would be your portal home URL, for example: 

https://machinename.esri.com/portal

You could try to connect to the portal first from Survey123 Connect and add the connection to your 10.7.1 portal. If you can successfully connect to the portal from Survey123 Connect, move on to the mobile device and make sure you connect to the same network as your Desktop Survey123 Connect and give it a try.

LeviCecil
Occasional Contributor III

Thanks. We're working with our IT department to get site-to-site VPN connection. Our Enterprise is hosted off site. 

We tried adding portal connection in Survey123 Connect, and were unable to. This is through an existing VPN connection to our network. We got the same error as the mobile app "Survey123 requires a base ArcGIS Enterprise Deployment"

Shwu-jingJeng
Esri Regular Contributor

Hi Levi,

What version of Survey123 field app or Connect you tried to log in? And just to confirm, when you tried to connect to survey123 from website, you received the certificate warning??

To sign in to your portal in the Survey123 website, browse to the following URL in your browser, with the provided example portal replaced with your own portal's URL:

https://survey123.arcgis.com/?portalUrl=https://machinename.esri.com/portal

Could you provide the screenshot you received from the web broswer to see what certificate it is asking for?

LeviCecil
Occasional Contributor III

Connect version 3.11.124. No, I got the certificate error from the mobile app. I navigate to that URL and everything looks good. But when I open the mobile app, I don't have the option to login through enterprise. When I try to add our Portal URL, it gives me the "Survey123 requires a base ArcGIS Enterprise Deployment" error. When I used that full example URL in the mobile app, it asks for certificates. 

 

Shwu-jingJeng
Esri Regular Contributor

Hi Levi,

What version of the field app and Connect are you using? As the web browser looked fine, it might still be the network issue. I will suggest you to contact Esri Support to log a ticket and have them troubleshoot the connection issue you are encountering as network issue would be more complicated to troubleshoot.

LeviCecil
Occasional Contributor III

Survey123 app version 3.11.164. 

LeviCecil
Occasional Contributor III

Our hosting contractor just figured it out. We just didn't have the datastore hosting configured yet.

View solution in original post