Can I change "or_other" language in the select_multiple [list_name]?

3570
2
Jump to solution
05-17-2016 02:47 PM
SergioDomenech_Zueco
New Contributor III

I would like to change the "Other" text label in the select_multiple [list_name] and "Specify other" because I need to put them in Spanish. Any help? Thanks in advance! 🙂

Reply
0 Kudos
1 Solution

Accepted Solutions
IsmaelChivite
Esri Frequent Contributor

Hi Sergio. I am attaching here an XLS file to show how to do what you are looking for. Essentially, you need to manually add a question so you can persist the value of 'other' and also add a relevant statement to make sure your 'other' question only shows when the 'other' option has been chosen in your list.  A lot  of people get trapped into thinking that the expression is something like ${SportsLiked} = 'other', but the  best expression is selected(${SportsLiked},'other'). In this way, the 'other' question will show every time you check the 'other' option. It will all make sense when you have a look at  the XLS file attached. It is quite simple.  I know this is a bit more complex than simply adding 'or other' after your select_multiple question... the shortcut only works in English....

View solution in original post

2 Replies
IsmaelChivite
Esri Frequent Contributor

Hi Sergio. I am attaching here an XLS file to show how to do what you are looking for. Essentially, you need to manually add a question so you can persist the value of 'other' and also add a relevant statement to make sure your 'other' question only shows when the 'other' option has been chosen in your list.  A lot  of people get trapped into thinking that the expression is something like ${SportsLiked} = 'other', but the  best expression is selected(${SportsLiked},'other'). In this way, the 'other' question will show every time you check the 'other' option. It will all make sense when you have a look at  the XLS file attached. It is quite simple.  I know this is a bit more complex than simply adding 'or other' after your select_multiple question... the shortcut only works in English....

View solution in original post

SergioDomenech_Zueco
New Contributor III

Thank you very much for your help, Ismael!

Reply
0 Kudos