Bug Found in Survey123 Version 3.3.64 That Concerns Repeats.

143
1
04-16-2019 05:06 PM
New Contributor II

I think I found a bug that has been introduced in newer versions of Survey123. Has anyone else observed the following?

When testing my survey in version 3.3.64, the requirement that at least one select_multiple is selected does not work when a new repeat is added. Only when the question is visible (the currently displayed repeat) does submitting the survey produce a requirement error. Attached is the XSLForm.

This survey works fine from Survey123: version 2.8.2.

Reply
0 Kudos
1 Reply
Esri Frequent Contributor

Hi Alexa,

Thanks for sharing your survey and above information. We have a known issue in latest version 3.3 with required fields not validating correctly on certain question types and in some circumstances. We are working to resolve this in 3.4.

Phil.

Reply
0 Kudos